Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

two server call are generated, one is getting through and another is gets failed

ashishr34155485
Level 1
Level 1

Hi everyone,

i have noticed that two AA server calls are getting generated on my site, out of this two server calls, 1st is getting through and 2nd is getting failed,

can someone have look on below screenshot, 

 
 

error.JPG

 

two server calls
1 Accepted Solution
Andrey_Osadchuk
Correct answer by
Community Advisor
Community Advisor

Ashish,

There must be a bug in your implementation. The beacon URL starts with this "https://https//wordpress-137997-650849.cloudwaysapps.com//b/ss/movementstaging/"

The part "https//wordpress-137997-650849.cloudwaysapps.com/" should have been the tracking server, but for some reason it's the wordpress URL. This server call has never reached Adobe Analytics.

The part "movementstaging" is the report suite ID that seems to be dummy in your case. This is another reason why this server call would not be preccessed even if the tracking server was correct.

View solution in original post

11 Replies
ashishr34155485
Level 1
Level 1
Error code is "net::ERR_NAME_NOT_RESOLVED"
AndrewWathen
Community Advisor
Community Advisor

There can be a few different reasons for this (not all bad), what was the status against the failed server call?  (the successful one will have had a status of "200")

AndrewWathen
Community Advisor
Community Advisor
Is the failed server call a link tracking call triggered on navigation from one screen to another? This is the only circumstance I've seen this "(failed)" status before. In this circumstance it doesn't necessarily mean that the server call has failed to reach Adobe i.e. data may still have been collected. In this circumstance, the failed status is returned when the navigation to the next screen completes before the response come back from the Adobe server (which shouldn't impact data collection as the request has already been sent and will probably have reached the Adobe server)
Andrey_Osadchuk
Community Advisor
Community Advisor
@AndrewWathen, I would not be so sure that the request that failed was successfully received by the analytics collection server. The data likely is not captured in case the status is not 200.
AndrewWathen
Community Advisor
Community Advisor
@Andrey_Osadchuk - that's a fair comment, I can't say these will be collected. Might be worth doing some testing if you are able to recreate the scenario.
Andrey_Osadchuk
Community Advisor
Community Advisor

Ashish, the request in the screenshot look very odd as it's referring to the incorrect URL (URI format). There may be a bug in the implementation.

 

Could you copy and paste here the full request (full URL) so we have a closer look and see what type of server call it is?

Andrey_Osadchuk
Correct answer by
Community Advisor
Community Advisor

Ashish,

There must be a bug in your implementation. The beacon URL starts with this "https://https//wordpress-137997-650849.cloudwaysapps.com//b/ss/movementstaging/"

The part "https//wordpress-137997-650849.cloudwaysapps.com/" should have been the tracking server, but for some reason it's the wordpress URL. This server call has never reached Adobe Analytics.

The part "movementstaging" is the report suite ID that seems to be dummy in your case. This is another reason why this server call would not be preccessed even if the tracking server was correct.

View solution in original post

jantzen_belliston-Adobe
Community Manager
Community Manager
Do any of the answers below give you the info you need? If so, could you mark the reply that answers your original question the best as correct? If not, can you provide additional details to help the community better solve your question?