Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

LiveCycle Es form--Acrobat 8 error message pops up "Invalid enumerated value: postSubmit"

Avatar

Level 2

I created a form in LiveCycle ES that has a submit button by email. When this form is opened in Acrobat 9, no error messages pop up. When it is opened in Acrobat 8 the error message pops up "Invalid enumerated value: postSubmit".  I have seen other discussions regarding this error, but no answers.  Is there a way to fix this?

6 Replies

Avatar

Level 10

Hi,

The postSubmit event is from XFA specification 2.8, so is only supported in Acrobat/Reader v9 or above.

It just doesn't exist in v8 - sorry.

Niall

Avatar

Level 2

Thanks, Niall.  Is it because of the submit button and email that is causing this problem.  I need to explain it to the customer so that she understands. Thanks again,

Maggie

Avatar

Level 10

Hi Maggie,

No, I don't think so. A standard 'submit by email' button works in earlier versions of Acrobat/Reader.

The issue is that you have script in the postSubmit event. This event did not exist in earlier versions, so that is why it is causing a problem in Acrobat/Reader v8.

I would delete/move the script to another event - it depends on what the script is trying to achieve.

Does that helps?

Niall

Avatar

Level 7

The problem is with LiveCycle Designer ES2 version 9.x. In this version under the File-> Form Properties if you select SetFocus and turn it on it puts the following code into the XML:

script>

<?templateDesigner expand 1?></variables> proto/> desc> text name="version">9.0.0.0.20091029.1.612548.606130</text> desc>

<?templateDesigner expand 1?>

event activity="postSubmit" ref="$form" name="event__postSubmit"> script contentType="application/x-javascript">//+ GENERATED - DO NOT EDIT (ID:881AD7B1-842A-4CF3-BE05-E05C44ED287E CRC:3815899415) script>

<

<

SetFocusOnFirstFailedField.DoSetFocusOnFirstFailedField(this);

//-

</

Notice in the above code the postSubmit event. This postSubmit event is not supported in versions of Acrobat/Reader prior to version 9. Even though you have set the file to support version 7 this remains in the code. I resolved this by turning off setFocus in the Form Validation.

<

<

<

</

</

Avatar

Level 10

Hi,

What I would add is that LC Designer has a Warnings tab. If you have selected a feature that is not supported in your target version, then it will warn you there:

Parallels Desktop1.png

So design your form, set your targer version, BUT check the warnings tab before you deploy. It is up to the forms developer to deselect options that are not supported by the target version that they set.

Hope that helps,

Niall

Avatar

Level 7

I agree that the warning tab is there and it lets you know there is a problem. It would be nice if it were

a bit more specific. I would also be nice if when you selected the option there was a warning on the dialog box when you

made the selection.