Highlighted

Issue with Events

JoshDBoyle-DVzR

20-02-2009

All



I am attempting to build a simple orchestration that is kicked off via the TaskCreated event. As of now, I don't care about using a filter - I just want the orchestration to run any time the TaskCreated event is fired.



I've created such an orchestration. First I placed a start point TaskCreated event on the canvas. I followed this with a SetValue operation that assigns some random sentence to a String variable. I've saved and activated this service.



Now, when I go into Workspace and launch a workflow, I can see in my log that the TaskCreated event seems to be firing properly but that something is definitely wrong. The following errors can be found in the server.log:



2009-02-20 17:21:55,491 ERROR [org.jboss.ejb.plugins.LogInterceptor] RuntimeException in method: public abstract java.lang.Object com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionCMTAdapterLocal.doSupports(com.adobe.idp.dsc.transaction.TransactionDefinition,com.adobe.idp.dsc.transaction.TransactionCallback) throws com.adobe.idp.dsc.DSCException:

com.adobe.workflow.template.document.TemplateNodeNotFoundException: Template object: STRT_ER1235167537085 not found.



I have Recording and Playback set for my orchestration with the event and a new instance of this orchestration is being fired whenever I create a task but it can't seem to actually make it past the event start point because of the above error.



Any ideas?

Replies

Highlighted
Highlighted

Jasmin_Charbonn

21-07-2010

If you remove the event start point do you get the error in the log?

Are you using an xdp or a pdf on the user step?

Is the form specified in a variable or you browse and select it from the repository?

Jasmin

Highlighted

bonpb

21-07-2010

When I remove the start point the process still fails. It seem to be when I add an event to a user block that causes the issue. I simply want to call an activity that writes to a log when the task is claimed.

To answer your other questions, I am using a xpd and it is specified in a variable.

Thanks for your help.

Highlighted

Jasmin_Charbonn

21-07-2010

" It seem to be when I add an event to a user block that causes the issue."

What do you mean by that? Are you trying to add an event catch to an actual user step.

I don't think you want to do that. What are you trying to do?

Jasmin

Highlighted

bonpb

21-07-2010

What I want to do is use an activity to write to a log when a task is claimed from a group. I would like to have the name of who claimed the task but at this point that is just for bonus points.

I have an activity that will write to my log (we use copies of this on several other steps). I want to use that activity to write a message to our log when a task is claimed. We create our reports and assign them to a group. I want to use our log writer activity when the report is claimed from that group. Here are a few of the things I have tried:

  • I placed an event on the corner of the user group

    • I wired this to a throw event thinking the startpoint process would catch it and write to the log but the process died

    • I wired this to the activity that writes to our log but the process died

    • I wired this to the activity that writes to our log and then back to the user but that caused issues

  • I placed a throw event on the process and did not link it to anything but it never fired

  • I placed an activity on the process and placed an even in the corner thinking it would catch the task claimed event but it didn't

Thank you for your help,

Parker

Highlighted

_Nith_

21-07-2010

The predefined events such as TaskCreated, TaskClaimed, TaskCompleted etc are always thrown automatically.

Which means, you need not drag those events into the corners of User activity.

It is just a matter of receiving those event (through event start points) by applying appropriate filters.

For a quick test,

     Create a simple (short-lived) process and add a event start point (say TaskCreated).

     Enable process recording.

     Initiate any process which has an user activity.

     You must be able to see the process recording if a task is assign to a user.

I faced Template Not Found exception. After a long research, I scraped my database and re-initialized. Because its just a TEST environment.

Nith

Highlighted

bonpb

28-07-2010

Thanks $Nith$, I got that to work.  Sorry for the delayed response, I took a fews days vacation.

I am now trying to pass data, specifially the reportName and the user that claimed it.  I am just starting to look at that and have not search the help or forums yet.

Highlighted

Jasmin_Charbonn

28-07-2010

Make sure the variable you use to pass the data are input variable.

This is a common mistake people make when trying to map data from the event to the process variables.

Jasmin