Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

CA config warning in error log

paulj26867979
Level 1
Level 1

I am frequently getting the below warnings in my error log whenever I access any page. Anyone know how to fix this.

I am using AEM 6.3 with SP2 and using editable templates for pages.

02.04.2019 16:24:03.577 *WARN* [0:0:0:0:0:0:0:1 [1554218643572] GET /content/site/en/test.html HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/site/settings from /conf/site/settings - Probably misconfigured as it ends with '/settings'

1 Reply
smacdonald2008
Level 10
Level 10

Are you seeing any strange behaviour in your page when you open it?

jbrar
Employee
Employee

Setup a DEBUG logger on "org.apache.sling.caconfig.resource" to get more info on this error.

paulj26867979
Level 1
Level 1

Its having the same error, however there is one more warning which I've noticed after moving to a dedicated logger

03.04.2019 09:36:14.732 *WARN* [0:0:0:0:0:0:0:1 [1554280574599] GET /content/site/en/test.html HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/site/settings from /conf/site/settings - Probably misconfigured as it ends with '/settings'

03.04.2019 09:36:15.287 *WARN* [0:0:0:0:0:0:0:1 [1554280575279] GET /conf/site/settings/wcm/templates/content-page/policies/_jcr_content.1326118631670.json HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/site/settings from /conf/site/settings - Probably misconfigured as it ends with '/settings'

jbrar
Employee
Employee

Looks like something is wrong at "/conf/site/settings/wcm/templates/content-page/policies/_jcr_content.1326118631670.json ". Try to remove this policy node and recreate it.

charityh8448708
Level 2
Level 2

That is most likely a red herring; a false lead. It is just likely another instance of the same error. I say this from 3-4 years experience in living with this error on just about every GET request that has anything to do with the editable templates. It is still happening in 6.5.3 too. 

Same error (pointing to same settings path) will present on non-template items too, such as:

  • /libs/wcm/core/content/pageinfo.json
  • /content/versionhistory.thumb.48.48.png
  • /favicon.ico
  • /etc/tags/marketing.infinity.json

If I ever find out the fix, you will likely hear me yell from the highest mountain top, but I'll also paste it here.

Ronny_Fallas
Level 2
Level 2

So, any workaround or fix for this message?

charityh8448708
Level 2
Level 2

Ok, so I found that apparently is an expected log entry, and so the alert was downgraded from warn to debug in August 2019. https://issues.apache.org/jira/browse/SLING-8637