Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Font upload problems

Avatar

Level 2

Hallo team,

I am having real problems getting fonts that I upload to register within the app. I have followed the instructions here:

https://helpx.adobe.com/digital-publishing-solution/help/cards-layouts.html

...but I can't get the fonts to register in my preview app when I assign them to card metadata.

I have rebuilt the app several times and reinstalled but no joy.

If anyone felt charitable enough to have a look at the code below and see where I have inevitably gone horribly wrong, I would be very grateful!

{

  "version": "1.0",

  "description": "Example font file.",

  "fonts": {

    "AkzidenzBold": {

      "fileName": "AkzidenzGrotesk-Bold.otf",

      "postScriptName": "AkzidenzGroteskBQ-Bold"

    },

  "AkzidenzBoldCondensed": {

      "fileName": "AkzidenzGrotesk-BoldCond.otf",

      "postScriptName": "AkzidenzGroteskBQ-BdCnd"

    },

  "AkzidenzBoldCondensedItalic": {

      "fileName": "AkzidenzGrotesk-BoldCondItalic.otf",

      "postScriptName": "AkzidenzGroteskBQ-BdCndIt"

    },

  "AkzidenzBoldItalic": {

      "fileName": "AkzidenzGrotesk-BoldItalic.otf",

      "postScriptName": "AkzidenzGroteskBQ-BoldItalic"

    },

  "AkzidenzCondensed": {

      "fileName": "AkzidenzGrotesk-Cond.otf",

      "postScriptName": "AkzidenzGroteskBQ-Cnd"

    },

  "AkzidenzCondensedItalic": {

      "fileName": "AkzidenzGrotesk-CondItalic.otf",

      "postScriptName": "AkzidenzGroteskBQ-CndIt"

    },

  "AkzidenzCondensedItalic": {

      "fileName": "AkzidenzGrotesk-CondItalic.otf",

      "postScriptName": "AkzidenzGroteskBQ-CndIt"

    },

  "AkzidenzItalic": {

      "fileName": "AkzidenzGrotesk-Italic.otf",

      "postScriptName": "AkzidenzGroteskBQ-Italic"

    },

  "AmplitudeBlack": {

      "fileName": "Font Bureau - Amplitude-Black.otf",

      "postScriptName": "Amplitude-Black"

    },

  "AmplitudeBold": {

      "fileName": "Font Bureau - Amplitude-Bold.otf",

      "postScriptName": "Amplitude-Bold"

    },

  "AmplitudeRegular": {

      "fileName": "Font Bureau - Amplitude-Regular.otf",

      "postScriptName": "Amplitude-Regular"

    },

  "RockwellRegular": {

      "fileName": "ROCK.TTF",

      "postScriptName": "Rockwell"

    },

  "RockwellBold": {

      "fileName": "ROCKB.TTF",

      "postScriptName": "Rockwell Bold"

    },

  "RockwellBoldItalic": {

      "fileName": "ROCKBI.TTF",

      "postScriptName": "Rockwell Bold Italic"

    },

  "RockwellItalic": {

      "fileName": "ROCKI.TTF",

      "postScriptName": "Rockwell Italic"

    },

   "StoneSerifRegular": {

      "fileName": "StoneSerifStd-Medium.otf",

      "postScriptName": "StoneSerifStd-Medium"

    },

  "StoneSerifBold": {

      "fileName": "StoneSerifStd-Bold.otf",

      "postScriptName": "StoneSerifStd-Bold"

    },

    "StoneSerifBoldItalic": {

      "fileName": "StoneSerifStd-BoldItalic.otf",

      "postScriptName": "StoneSerifStd-BoldItalic"

    },

    "StoneSerifRegularItalic": {

      "fileName": "StoneSerifStd-MediumItalic.otf",

      "postScriptName": "StoneSerifStd-MediumItalic"

    }

  }

}

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi guys,

Andrei (who owns our cards and layouts feature) was able to reproduce this issue in-house with the zip file provided by Ian. We're not sure why, but I've asked the App Builder team to investigate.

Neil

View solution in original post

0 Replies

Avatar

Level 6

I suspect the leading value. Increase that and see what happens.

I don't think that your other settings would lead to truncation.

Avatar

Level 3

Doesn't fix it. I've increased it significantly just to see if it fixes the problem. Really frustrating. We feel like we've exhausted all possible setting changes.

Avatar

Employee

Hi,

Can you send me a screenshot with the cropped descenders? (you're using iOS, correct?)

Also, what font are you using? Does the same occur with other fonts you may have tested? (it would be great if you could provide us the font file so we can test it on our end). It may be a rendering glitch with that specific font.

Thanks,

Andrei

Avatar

Level 3

Yes, we're using iOS. What email should I send screenshots and fonts to?

Avatar

Level 2

Do make sure that your JSON is properly formed. This tool is a good way to

catch problems. Copy+Paste your font JSON into it.

http://jsonlint.com

Scott Dreier

sr. product manager | digital publishing | adobe | +1 415 832 2790 office

| +1 415 640 7206 mobile

Avatar

Level 2

I'm still having problems getting my fonts to pick up. Worth noting re: the above point about properly formed .json files, that when I download the sample font .json file from here:

Digital Publishing Solution Help | Create cards and layouts

....on my PC and run it through JSONLint, it reports an "unexpected token error"....!

However, I have got a valid font .json now, and I have been careful to copy the exact font names. I've rebuilt the app today, but no joy getting it to register in the app, I'm afraid. Is there anyone who I can send my files to to take a quick look? As someone has pointed out above, this is a fairly significant obstacle to development - not least because the default font weight is not editable so I can't add bold or italic formatting to my card metadata as I would like...

I'm running Windows 7 Professional to build the app. I then have to sign the app on my Macbook Pro running OSX Yosemite to upload it onto my iPad.

All help gratefully received!

Thanks

Avatar

Employee

Hi,

Can you send me your font zip file via a file transfer to ganci@adobe.com? I'll take a look.

Thanks,

Avatar

Employee

When creating the manifest, please make sure the json file is actually named "font-manifest.json". If you name it fonts.json, fonts won't be baked in the app properly and won't work. (this was the problem this time around)

We're looking at "manifest-free" font management in the near future.

Andrei

Avatar

Level 1

I am also having an issue with the descenders cutting off. Was this issue resolved?

Avatar

Employee

Hi,

Usually the issue with descenders being clipped is the font file itself and the way the baselines were set up in the font file. What solved the problem in the few cases we encountered was opening the font in a glyph editing tool and adjusting the cropping line them so it is lower than the descenders.