Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Event not covered error for transactionnal message

thibaultb473199
Level 4
Level 4

Hello everyone,

I got an issue that involve my transactionnal message when trying to link a template I create with an event using SoapUI.

I already see another post on the forum but with no real answers on my issue.

So I first make a simple template and create an event name to specify the event type of the template and I publish the template with success.

I also send a proof with no problem.

I then make a SoapRequest such as this :

SoapUI-5.4.0_2018-04-10_09-48-22.png

I got a success answer :

SoapUI-5.4.0_2018-04-10_09-49-20.png

But still, when I check in the Adobe Campaign's event history, my events are not covered and the documentation doesn't help get through the problem.

nlclient_2018-04-10_09-52-38.png

I already check in the properties of the template to make sure the event name is correct and it's the case.

I also see that lots of people are facing this issue, do you have some answers for my problem ?

If you need more information, feel free to ask me !

Using Adobe Campaign v7 on Windows 10.

Regards,

Thibault

0 Replies
shrawans3153003
Employee
Employee

Hi Thibault,

Usually when event status is "event not covered", it means MC routing phase didn't find any eligible template for your event. Please check that

you pushed the event with the proper operator

you have published your template

your template has the proper event type and the proper channel

Please go through below link to know more on this.

Introduction

thibaultb473199
Level 4
Level 4

Hello shrawans31530030

So I check all of what you ask and I'm facing another issue.

I push the event with the proper operator but go an error when pushing as see on those screens :

SoapUI-5.4.0_2018-04-10_10-44-04.png

SoapUI-5.4.0_2018-04-10_10-44-30.png

Here are my methods, Javascripts and dataSchema I use for this :

nlclient_2018-04-10_10-46-50.png

nlclient_2018-04-10_10-47-22.png

Then the publish of my template is good :

nlclient_2018-04-10_10-48-51.png

And in the properties, my template has the proper event type and the proper channel :

nlclient_2018-04-10_10-49-17.png

Maybe it's coming from the SoapUI request error when I try to log with the mc operator.

Any idea on that ? Thank you.

Thibault

EDIT :

Also, I don't understand this part of the documentation concerning the screen with <batchEvent>

chrome_2018-04-10_13-57-29.png

They say : Definition of the event type in the event properties.

Where can I find those event properties or should I make something with batch ? I am confuse with that.

Thank you for your answers !

Thibault

thibaultb473199
Level 4
Level 4

Hello everybody,

Any idea on how to fix that "event not covered" issue or it maybe happened to someone recently ?

Thibault

Jean-Serge_Biro
Community Advisor
Community Advisor

Bonjour Thibault,

Perhaps a stupid question, but did you already add your event item in the dbEnum enumeration?

https://docs.campaign.adobe.com/doc/AC/en/MCE_Instance_configuration_Creating_event_types.html

Cordialement.
J-Serge

thibaultb473199
Level 4
Level 4

Hello Jean-Serge,

This step is done as well on the screen below :

nlclient_2018-04-16_07-34-36.png

Still have no idea on how to fix that, any more ideas ?

Thibault

Jean-Serge_Biro
Community Advisor
Community Advisor

Bonjour Thibault,

Because you have extended the nms:rtEvent schema with cus:rtEvent, your Javascript function should be named accordingly:

cus_rtEvent_envoiMailTransactionnel

Cdt

J-Serge

thibaultb473199
Level 4
Level 4

Hello Jean-Serge,

I still got the same issue on my SoapRequest even with that function name modification. (Too many arguments)

And the event not covered still remain.

Jean-Serge_Biro
Community Advisor
Community Advisor

Thibault,

You forgot to write your argument xml xmlEnvoyer in your Javascript function cus_rtEvent_envoiEmailTransactionnel.

BR
JS

thibaultb473199
Level 4
Level 4

Hello Jean-Serge,

Yes I notice that error and I change it already few days ago, sorry for not updating that.

it looks like that for now :

nlclient_2018-04-11_11-13-39.png

Or with the function change name :

nlclient_2018-04-16_11-24-02.png

The error in my SoapRequest for reminder :

SoapUI-5.4.0_2018-04-16_11-28-22.png

Regards,

Thibault

Jean-Serge_Biro
Community Advisor
Community Advisor

It is strange, the error still mentions the nms:rtEvent instead of your cus method.

Jean-Serge_Biro
Community Advisor
Community Advisor

Please add xmlEnvoyer in your logInfo in order to debug

thibaultb473199
Level 4
Level 4

Yes I noticed it mentions the wrong method.

When I check the log, it gives me that :

nlclient_2018-04-16_11-55-08.png

Jean-Serge_Biro
Community Advisor
Community Advisor

Ajoute xmlEnvoyer, le paramètre que tu as ajouté en argument, au logInfo. Peut-être est-il vide.

Please check the value of xmlEnvoyer as parameter to logInfo, perhaps it is empty value.

thibaultb473199
Level 4
Level 4

Quand je rentre le xmlEnvoyer, il me renvoie un \n, qu'est ce que ca signifie ?

When i put the xmlEnvoyer, he gives me back a \n, what does that mean ?

nlclient_2018-04-16_13-23-39.png

parveshp7822672
Level 3
Level 3

Hello,

Make sure you are sending the soap request with the same operator, using which you have connected your execution server with the control server. i.e mc.

So Firstly take a session token from mc user -

1541255_pastedImage_0.png

Then use this token within your request.

1541256_pastedImage_1.png

I was using the different operator then I got the same issue. But after that I tried with mc then issue is resolved.

Thanks.

Parvesh.