Event not covered error for transactionnal message

thibaultb473199

10-04-2018

Hello everyone,

I got an issue that involve my transactionnal message when trying to link a template I create with an event using SoapUI.

I already see another post on the forum but with no real answers on my issue.

So I first make a simple template and create an event name to specify the event type of the template and I publish the template with success.

I also send a proof with no problem.

I then make a SoapRequest such as this :

SoapUI-5.4.0_2018-04-10_09-48-22.png

I got a success answer :

SoapUI-5.4.0_2018-04-10_09-49-20.png

But still, when I check in the Adobe Campaign's event history, my events are not covered and the documentation doesn't help get through the problem.

nlclient_2018-04-10_09-52-38.png

I already check in the properties of the template to make sure the event name is correct and it's the case.

I also see that lots of people are facing this issue, do you have some answers for my problem ?

If you need more information, feel free to ask me !

Using Adobe Campaign v7 on Windows 10.

Regards,

Thibault

Replies

Highlighted

shrawans3153003

Employee

10-04-2018

Hi Thibault,

Usually when event status is "event not covered", it means MC routing phase didn't find any eligible template for your event. Please check that

you pushed the event with the proper operator

you have published your template

your template has the proper event type and the proper channel

Please go through below link to know more on this.

Introduction

Highlighted

thibaultb473199

10-04-2018

Hello shrawans31530030

So I check all of what you ask and I'm facing another issue.

I push the event with the proper operator but go an error when pushing as see on those screens :

SoapUI-5.4.0_2018-04-10_10-44-04.png

SoapUI-5.4.0_2018-04-10_10-44-30.png

Here are my methods, Javascripts and dataSchema I use for this :

nlclient_2018-04-10_10-46-50.png

nlclient_2018-04-10_10-47-22.png

Then the publish of my template is good :

nlclient_2018-04-10_10-48-51.png

And in the properties, my template has the proper event type and the proper channel :

nlclient_2018-04-10_10-49-17.png

Maybe it's coming from the SoapUI request error when I try to log with the mc operator.

Any idea on that ? Thank you.

Thibault

EDIT :

Also, I don't understand this part of the documentation concerning the screen with <batchEvent>

chrome_2018-04-10_13-57-29.png

They say : Definition of the event type in the event properties.

Where can I find those event properties or should I make something with batch ? I am confuse with that.

Thank you for your answers !

Thibault

Highlighted

thibaultb473199

13-04-2018

Hello everybody,

Any idea on how to fix that "event not covered" issue or it maybe happened to someone recently ?

Thibault

Highlighted

thibaultb473199

15-04-2018

Hello Jean-Serge,

This step is done as well on the screen below :

nlclient_2018-04-16_07-34-36.png

Still have no idea on how to fix that, any more ideas ?

Thibault

Highlighted

Jean-Serge_Biro

MVP

16-04-2018

Bonjour Thibault,

Because you have extended the nms:rtEvent schema with cus:rtEvent, your Javascript function should be named accordingly:

cus_rtEvent_envoiMailTransactionnel

Cdt

J-Serge

Highlighted

thibaultb473199

16-04-2018

Hello Jean-Serge,

I still got the same issue on my SoapRequest even with that function name modification. (Too many arguments)

And the event not covered still remain.

Highlighted

Jean-Serge_Biro

MVP

16-04-2018

Thibault,

You forgot to write your argument xml xmlEnvoyer in your Javascript function cus_rtEvent_envoiEmailTransactionnel.

BR
JS

Highlighted

thibaultb473199

16-04-2018

Hello Jean-Serge,

Yes I notice that error and I change it already few days ago, sorry for not updating that.

it looks like that for now :

nlclient_2018-04-11_11-13-39.png

Or with the function change name :

nlclient_2018-04-16_11-24-02.png

The error in my SoapRequest for reminder :

SoapUI-5.4.0_2018-04-16_11-28-22.png

Regards,

Thibault