Unable to link/join a schema with recipient schema

Avatar

Avatar

sonikad8559822

Avatar

sonikad8559822

sonikad8559822

20-09-2018

Hello,

I have use case that : "optIn Schema ", should have link to Recipient schema, where Recipient-Id will be foreign key in "optIn Schema ".

I have linked the schema in following way:

1575512_pastedImage_2.png

  • When I am trying to insert any record in optIn Schema using workflow I am getting below error:

1575516_pastedImage_0.png

  • When I am trying to expand and see values from DATA Tab in Schema, I am getting following error:

1575514_pastedImage_6.png

Please let me know how to resolve this.

cc: Adhiyan​, Vipul Raghav

Replies

Avatar

Avatar

Vapsy

Employee

Avatar

Vapsy

Employee

Vapsy
Employee

20-09-2018

Hi sonikad8559822,

You need to create an attribute with name recipientId inside your OptIn schema.

I can see that you have given the same . name to link element but as per your definition it will look for an attribute with same name.

Regards,
vipul

Avatar

Avatar

sonikad8559822

Avatar

sonikad8559822

sonikad8559822

20-09-2018

Hi vipul,

Can you please elaborate I am not able to understand?

Regards,

Sonika

Avatar

Avatar

sonikad8559822

Avatar

sonikad8559822

sonikad8559822

20-09-2018

Vipul Raghav

This is my schema:

1575525_pastedImage_1.png

Avatar

Avatar

Adhiyan

Employee

Avatar

Adhiyan

Employee

Adhiyan
Employee

20-09-2018

Hello Sonika,

Try to update the  Xpath for the source with this expression and see if you still get the error

xpath-src="@recipient-id"/>

Regards,
Adhiyan