Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Split activity -complementary set is not working correct

Avatar

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
vaidehig2773360
Level 2

06-12-2018

Hello

I have a problem with my split activity in adobe campaign classic

The issue is the complement set of split activity is not giving the results,it always gives the total number records passed to the split activity in the workflow

I am sharing my screen captures  here

Capture1.PNG

Capture2.PNG

Capture3.PNG

I am looking forward someone's help resolving this issue.

Thanks

Vaidehi

Replies

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

07-12-2018

Hi Vaidehi,

You forgot to define the sort criteria (order by), please select a field of your filtering dimension.

Regards

J-Serge

Avatar

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
vaidehig2773360
Level 2

09-12-2018

Hello J-Serge

I have selected the field of my filtering dimension, still it is not giving the right complementaryCapture4.PNG set.

1642790_pastedImage_1.png

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

10-12-2018

HI Vaidehi,


Ok 1st mistake repaired, now I think you should address the 2nd one; please select the 1st checkbox because you didn't use a criteria of your additional data to do the split but directly the targeting dimension "Data_loading (RDBMS)" (actually the primary key is used, because it is done with a top instruction) :
1643032_pastedImage_0.png


Regards
JS

Avatar

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
vaidehig2773360
Level 2

10-12-2018

Hi Jean-Serge

Thanks for your reply, sorry for the duplicate thread,

If select the first radio button, it automatically comes to use additional data only, still I am seeing the same issue, complementary set is not giving the correct records.

FYI

The first activity in the workflow import the data from the external database, there is no primary key(mid) is not primary key there.

Thanks

Vaidehi

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

10-12-2018

Sorry Vaidehig if your criteria to select comes from the external data source, so it is the 3rd choice radio button that you must choose.

Avatar

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
vaidehig2773360
Level 2

Likes

6 likes

Total Posts

18 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
vaidehig2773360
Level 2

10-12-2018

Hi Jean-Serge

1643516_pastedImage_0.png

This is the configuration for Data Loading activity, we are importing it from external Data source,then the data is coming to Split activity, then no need to again configure the external data source in split activity right, that is my understanding, please correct me I am wrong,

Thanks

Vaidehi

Avatar

Avatar
Validate 1
Level 1
christopher1544
Level 1

Likes

0 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
christopher1544
Level 1

Likes

0 likes

Total Posts

6 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
christopher1544
Level 1

13-12-2018

I'm having the exact same problem.    I have a split following another split.   No matter what I seem to do though, the matches go down one path, but the complement still has all of the records.   For example:

Split 1:  Matches 10,000 records

Split 2:  Matches 1,000 records, but the complement still has 10,000 records

Capture.PNG

Settings for my account type split

Capture2.PNG

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

352 likes

Total Posts

464 posts

Correct Reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

19-12-2018

can you try the 3rd checkbox please ?

Avatar

Avatar
Validate 10
Level 2
sagil23995776
Level 2

Likes

17 likes

Total Posts

32 posts

Correct Reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile

Avatar
Validate 10
Level 2
sagil23995776
Level 2

Likes

17 likes

Total Posts

32 posts

Correct Reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile
sagil23995776
Level 2

19-12-2018

I Had the same problem also.

Found out that if there is no primary key in the inbound temp table then the complement is not working correctly.

So I needed to use one of two options:

1. keep a key field in the temporary table.

2. Adding another transition to the split and specify the complement rule instead of using the complement.
for example if the split is for 'age >18' then instead of using complement, add another out transition to the split specifying 'age<18' (and remove the check box from the complement)