TLS support on Adobe Campaign v6.02

Avatar

Avatar
Validate 1
Level 1
momokh
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
momokh
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
momokh
Level 1

13-11-2018

We've just upgraded to adobe campaign v6.02

after enabling TLS support in the serverConf.xml file

<smtp enableTLS="true" idleSessionTimeoutSec="5" initialDelaySec="4" maxSessionsPerChild="1000">

We start getting the following error, cpu was 100% by process and no outbound emails were processed.

2018-11-11 12:58:06.074-05         00001104             000003B8               1           error      log          Error in SSL library: 'error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version (code 336032814)' (iRc=-53)

Had to disable TLS support for outbound emails to be delivered. Now all emails are being sent with no tls encryption.

How is TLS support enabled in v6.02 , also where are the ssl certs being used by Adobe Campaign during tls encryption? I didn't install any certs during the v6.02 upgrade...not quite sure how TLS works with no certs installed on adobe campaign. Thanks

Replies

Avatar

Avatar
Validate 250
Level 10
pablo_rosero1
Level 10

Likes

81 likes

Total Posts

348 posts

Correct reply

77 solutions
Top badges earned
Validate 250
Validate 100
Validate 50
Validate 25
Validate 10
View profile

Avatar
Validate 250
Level 10
pablo_rosero1
Level 10

Likes

81 likes

Total Posts

348 posts

Correct reply

77 solutions
Top badges earned
Validate 250
Validate 100
Validate 50
Validate 25
Validate 10
View profile
pablo_rosero1
Level 10

03-12-2018

Hi Mohamed,

Are you using Salesforce TLS with the Campaign CRM connector? If so, support was discontinued on July, 2017: Salesforce TLS 1.0 support ending and Campaign

Please contact your customer success manager or account manager to review the upgrade options for your system. A migration for a version prior to 6.1.0 to a 6.1.1 or v7 needs to be analyzed by our Professional Services.

Hope this helps!

All the best,

Pablo