Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

RE: BULK DATA INSERTION API ISSUE

Avatar

Level 1

Hello,

I am using my sandbox Adobe Analytics report suite, to upload server calls using the bulk data insertion API. I was successfully able to upload my compressed batch file (csv columns format) using curl command on windows terminal. Also, I got successful response in terminal saying input rows processed and uploaded successfully. After successfully uploading and waiting for 2 days, I still do not see any data in my report suite, event page names is not being captured. I am attaching my batch file and screenshot from my terminal. I am not sure why the data is not being reported in Adobe Analytics reports. If anyone could provide their thoughts here would be really helpful.

terminal command responseterminal command response

 

This is my batch file with csv columns and fields i uploaded -

marketingCloudVisitorID,pageName,timestamp,reportSuiteID,visitorID,userAgent,campaign,contextData.color,contextData.frame,pageURL,prop1,channel
39403271176217385201682635945656896342,home,1495483797,ageo1xxsintestmumbai,238915514,"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1 ""Special
Build""",Summer,Red,Titanium,http://somedomain.org/path?param=val&param2=val2,p2,Mobile
39403271176217385201682635945656896342,PDP,1495483797,ageo1xxsintestmumbai,142805255,"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1 ""Special
Build""",Summer,Gray,Carbon,http://somedomain.org/path?param=val&param2=val2,p2,Mobile

 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

There was a bug with the BIA configuration. It is fixed now. Can you try sending the data again and see if that makes it to the reports?

View solution in original post

1 Reply

Avatar

Employee

Could you please check and share the status of the file you uploaded by using the following Endpoint:

Method: Get
Endpoint: https://analytics-bia-us1.cloud.adobe.io/fileingest/file/<file_id>

File_id is available in the screen shot you shared.

Avatar

Level 1
Hello, to make this GET request, it is asking for authentication, what all authentication parameters do I need to send in query string parameters ?

Avatar

Employee

vibhatna_0-1594047657780.png

Please check and confirm if you have above parameters mentioned in the request.

Avatar

Correct answer by
Employee Advisor

There was a bug with the BIA configuration. It is fixed now. Can you try sending the data again and see if that makes it to the reports?

Avatar

Level 10
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?

Avatar

Level 2

Hi All, 

I am also facing the same issue as "akshaya79742116", After making a successful call using Bulk Data insertion API (BDIA) I am getting success response but I don't see data populated in eVars and events in my report suite.

Any solution suggestion is highly & highly appreciated as we plan to go live in this week itself and this issue has been a roadblock for now.

Details :

API URL : https://analytics-collection.adobe.io/aa/collect/v1/events

Environment : Production (Adobe Analytics) 

 

Regards

Guptaa

Avatar

Employee Advisor

@CSLTGUPTAA There can be multiple reasons why the data is not reflecting adobe analytics reporting even when the BDIA ingestion is successfull, one of them is time stamp configuration of the report suite,

the report suite needs to be enabled for timestamp, otherwise the hits can be excluded while processing

You can find timestamp settings at Analytics > Admin > Report Suites > General > Timestamp Configuration.

 

You can check the data feeds to see if the hits are getting excluded , check for the column exclude_hit, any value apart from zero in this column , the hit is excluded 

 

Here is the documentation on the same 

https://experienceleague.adobe.com/docs/analytics/export/analytics-data-feed/data-feed-contents/data...

 

Avatar

Level 2

Hi @VaniBhemarasetty 

you are simply awesome!! 

You encountered the issue at the heart and 'timestamp' enabled fixed this issue.

I can't only thank you but I would rather say : you simply save my production date.

Many thanks!!!

 

Regards

Guptaa

Avatar

Employee Advisor

@CSLTGUPTAA  Glad to know that the issue is resolved. 

 

Have a great day ahead !

 

Regards

Vani

Avatar

Level 1

Hello, I'm attempting to validate my gzipped CSV against the validation endpoint. Using the CSV posted above (swapped out the information to match my own), when I send the request, I get the following error:

gid=749149485 found in the header row in column 1. This column will be ignored.
No visitor ID found in the file header. There must be one of VisitorID, MarketingCloudVisitorID, IPAddress, or CustomerID defined.
There must be one of QueryString, PageName, or PageUrl defined in the file header.
No ReportSuiteID found in the file header. This must be present in order to submit a hit.
No timestamp field found in the file header.
No user-agent found in the file header.
On row: 3, inconsistent column count. Expected 1 columns, but found 2.
On row: 6, inconsistent column count. Expected 1 columns, but found 8.
On row: 7, inconsistent column count. Expected 1 columns, but found 7.
On row: 8, inconsistent column count. Expected 1 columns, but found 7.
Processing complete: 0 rows will be submitted. 8 rows were invalid.
No valid rows were found in the file.

 I definitely have these columns defined so I'm not sure why this isn't validating. 

Any thoughts?