Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error: 'Unable to save segment' when updating existing segments

heijk508
Level 1
Level 1

Hello,

 

Unfortunately I get an error 'Unable to save segment' when I want to update an existing segment. It concerns all existing segments. The content of the segment and the ownership should not be the issue as when I create a new segment with the same content it does not show the error and I am the owner of the segments. Could somebody help me?

 

I do not get the error when creating a new segment or when clicking on 'Save as' in an existing segment.

 

Many thanks in advance,

Hanneke

1 Accepted Solution
Saurav_Raj
Correct answer by
Level 2
Level 2

Adding to Ishan's comment, We had similar issue reported yesterday where on clicking 'Save' button, Users were getting 'Unable to Save segment error'.
Despite the error, the changes were going through. A fix for the error has already been rolled out and the error is not reproducible anymore. I'm not sure if this related to the error you are noticing.

 

The best bet here will be by creating a ticket with Client Care to know the root cause.

View solution in original post

6 Replies
ishans52004352
Employee
Employee

That must be a known bug, however, it shouldn't affect the segment creation or update of segments. In other words, the segments will be updated or created even though the error is seen. If that's the case, you can reach out to the Client Care team to get rid of that low priority bug.

However, if you see that the segments aren't being updated or created, let the Client Care team know about it to submit a high priority bug to the Engineering Team.

Saurav_Raj
Correct answer by
Level 2
Level 2

Adding to Ishan's comment, We had similar issue reported yesterday where on clicking 'Save' button, Users were getting 'Unable to Save segment error'.
Despite the error, the changes were going through. A fix for the error has already been rolled out and the error is not reproducible anymore. I'm not sure if this related to the error you are noticing.

 

The best bet here will be by creating a ticket with Client Care to know the root cause.

View solution in original post

DaBiznis
Level 1
Level 1

Our team has gotten the same error a few times over the last week or so. Personally the way I avoided it was to just go into Segments and create there and Publish and save and then update components in the dashboard, currently open in another tab.

 

Though it was intermittent, it seemed to occur over and over at certain times. Thinking the issue was with the monthly update.

 

Haven't see this for a few days now.

 

metripat
Level 2
Level 2
@DaBiznis - Yes, your understanding is correct.  The issue has been fixed by our monthly release on 17th June. In case you still see issues anytime in the future, please create a ticket with the Client Care team to get this checked.
heijk508
Level 1
Level 1
Yeah seem to be solved again, thanks for your answers 🙂
jantzen_belliston-Adobe
Level 10
Level 10
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?