since ‎06-08-2013
‎10-12-2019
Rich_Clem
Level 2
Changing clustering from Shared Journal to Shared Nothing, Possible? Rich_Clem - Adobe Experience Manager Forms
We are looking to cluster our CQ5.3 Author instance. By default this comes configured to cluster with the Journal Shared. We have recently upgraded the CRX to 2.2 which allows for Shared Nothing clustering. I have had a look into this and there doesn't appear to be a way to "switch" the type of clustering easily. I tried removing clustering altogether on a test instance, by removing the Cluster entry in the repository.xml, and this just ends up corrupting the instance. It seems you have to have ...
126
Views
0
Likes
0
Answers and Comments
Re: Send Email workflow step comments in an email to initiator Rich_Clem - Adobe Experience Manager
No sorry, its in the actual step item details. I can get the Workflow instance "Start comment" using, ${instance.data.startComment}Its the comment that actually gets entered into the participant step when the workflow user actions their inbox. I think I can get the step ID using, ${item.id}That give me something like VolatileWorkItem_node9_etc_workflow_instances_2015-06-10_model_49688341059757941I believe the comment is placed under [workflowinstance]/workitem/metadata.comment , as it is there o...
154
Views
0
Likes
0
Answers
Send Email workflow step comments in an email to initiator Rich_Clem - Adobe Experience Manager
I am setting up am approval/reject workflow to authorise activations. I am setting up an email template to send the initiator to let them know if the activation has been rejected. I would like to include the "comments" that can be put in the "Participant Step", if they decide to reject the request. Is there a way to do this? Will the "Send Email" step pickup the comments from the previous "Participant Step" that causes the rejection?So far in the email template I have,From: Global IT activation ...
655
Views
0
Likes
5
Answers and Comments
Trouble importing using vlt Rich_Clem - Adobe Experience Manager
I am looking to transfer some content between two 5.3 instances, but I cannot get the import to work. I have tried this in 5.6.1 and I get the same issue. I have carried the following,Exported usingC:\Development\export>vlt --credentials admin:admin export -v http://localhost:4502/crx /content/vault vaultTried ImportingC:\Development\export\vault>vlt import -v http://localhost:4502/crx . /Connecting via JCR remoting to http://localhost:4502/crx/serverCollecting import information...Installing no...
89
Views
0
Likes
2
Answers and Comments
Re: CQ logs in straight into the welcome screen as the wrong user with Firefox Rich_Clem - Adobe Experience Manager
Sham HC wrote... Another possibility could be SSO but still uses login token. might be serving stale. Browser cache issue or webserver caching issue. Hi I did clear the webserver doc cache out and restart it. Also I don't believe it is stale content as the welcome page is displaying a user name that has never used the PC in question. This user name seems to be different every time. It has also indicated that the user is logged in as Administrator, when that account has never been used.This only ...
108
Views
0
Likes
0
Answers
CQ logs in straight into the welcome screen as the wrong user with Firefox Rich_Clem - Adobe Experience Manager
We are currently using CQ 5.4 (in the plans of upgrading), but some of our users are finding they are opening Firefox, then going to CQ author, and being logged straight in, but with the wrong user details. This doesn't seem to occur under IE or Chrome. Anyone else experienced this or know of a hotfix? If users go to the SiteAdmin it then says the user is Anonymous and doesnt display any sites. The issue doesn't always occur even in FirefoxI did notice that the login-token cookie does not seem t...
126
Views
0
Likes
3
Answers and Comments
Re: Changing clustering from Shared Journal to Shared Nothing, Possible? Rich_Clem - Adobe Experience Manager
Thats Brrilliant, exactly what I needed, really appreciated, Thanks Sham HC
149
Views
0
Likes
0
Answers
Re: Changing clustering from Shared Journal to Shared Nothing, Possible? Rich_Clem - Adobe Experience Manager
We are quite aware that CQ5.3 is EOL. Your answer is hardly useful.
130
Views
0
Likes
0
Answers
Re: Changing clustering from Shared Journal to Shared Nothing, Possible? Rich_Clem - Adobe Experience Manager
Hi Jörg.We do have the latest CRX2.2 which supports Shared Nothing clustering. But it appears when you "install" CQ5.3 it builds itself with the old type of clustering, and even though the new version is available, it doesnt appear to be possible to migrate to this in situ. I was just wondering if any one had a easy trick to doing this. We certainly would like to move to a later version of AEM, but this is not an easy process for us.TBH I cannot get the shared journal form of clustering working ...
131
Views
0
Likes
0
Answers
Changing clustering from Shared Journal to Shared Nothing, Possible? Rich_Clem - Adobe Experience Manager
We are looking to cluster our CQ5.3 Author instance. By default this comes configured to cluster with the Journal Shared. We have recently upgraded the CRX to 2.2 which allows for Shared Nothing clustering. I have had a look into this and there doesn't appear to be a way to "switch" the type of clustering easily. I tried removing clustering altogether on a test instance, by removing the Cluster entry in the repository.xml, and this just ends up corrupting the instance. It seems you have to have ...
382
Views
1
Like
6
Answers and Comments
Problems getting forum notifications to work Rich_Clem - Adobe Experience Manager
I am having trouble getting the forum notifications to work in CQ5.4. Everything else is working fine.I can create topics and replies etc. I have noticed in the error log,28.03.2014 15:16:59.180 *ERROR* [JobHandler: /etc/workflow/instances/2014-03-28/model_11771317718749671:/content/usergenerated/content/intranet/en_ho/site/home/squiggle4/jcr:content/forum/vsjb-topic_3] etc.workflow.scripts.collab.log_activity$ecma Could not create comment activity. Missing author identifier.Looking at the ecma ...
63
Views
0
Likes
0
Answers and Comments
Re: Is there a known issue with 5.6.1 and IE8 opening pages in Author? Rich_Clem - Adobe Experience Manager
Checking again the instance that doesn't work also has spk2 on. So it is definitely something in there that's caused the problem. Looks like something Adobe need to fix
106
Views
0
Likes
0
Answers
Re: Is there a known issue with 5.6.1 and IE8 opening pages in Author? Rich_Clem - Adobe Experience Manager
Thanks for the reply1 Removing the cf. Yes it displays the page, but sort of stops you authoring the page2 Not sure why this would help, but tried it and it doesn't make any difference3 Not sure why this would help, but tried it and it doesn't make any differenceI have logged a support call with Adobe to look into this, but any other suggestions gratefully received, as this has put a hold on us migrating from CQ 5.4
107
Views
0
Likes
0
Answers
Re: Is there a known issue with 5.6.1 and IE8 opening pages in Author? Rich_Clem - Adobe Experience Manager
I have rechecked my investigations, and it appears IE8 does work with a completely fresh install of AEM 5.6.1. I then tried adding the Security Pack 1 and the fix for IE11 browsers, and it still worked. As soon as I installed service pack 2 it broke author with the content finder. We do have another separate instance we upgraded to 5.6.1 which doesn't have spk2 on though and that doesn't work either. Looks like I need to do a bit more digging.
107
Views
0
Likes
0
Answers
Is there a known issue with 5.6.1 and IE8 opening pages in Author? Rich_Clem - Adobe Experience Manager
Is there a known issue in AEM 5.6.1 opening pages for authoring using IE8. According to the supported browsers, IE8 is supported in classic mode. But on opening the page we are getting a blank screen. If I remove the content finder from the URL it then works. I have tried spk2 as well and that has made no difference.Thanks
229
Views
0
Likes
6
Answers and Comments
Re: Issue with using xtype authselection Rich_Clem - Adobe Experience Manager
Ah sorted my problem. It was the access set to the users under the home folder. It had been set so they only had read access to the profile node. Just tested a user with jcr:all access and the list is working. Just need to work out the minimum access I can give the users.
113
Views
1
Like
0
Answers
Issue with using xtype authselection Rich_Clem - Adobe Experience Manager
We have setup a tab on the content page properties for one of our templates. This is to allow an author to manually set the page owner. We have a field which is to allow the author to pick the name of the page owner using a text field, which is an xtype of authselection. This should provide the ability to select from the list of CQ users.This works when logged in as administrator, but when logged in or impersonating one of the authors, it only shows that author in the selection list, and you can...
277
Views
1
Like
1
Answers and Comments
Re: Trying to setup a workflow to intercept page deactivations Rich_Clem - Adobe Experience Manager
Any ideas where I can find out?None of the Adobe workflow documentation I have looked at gives this information
107
Views
0
Likes
0
Answers
Trying to setup a workflow to intercept page deactivations Rich_Clem - Adobe Experience Manager
HelloI am trying to set up a workflow which will intercept page deactivations from the root level and down 2 levels only. This will allow the administrator to decide if the the deactivation is authorisedI am trying to use a launcher, but I am having trouble setting it up. I am using an Event Type of modified and Node Type of page, but this seems to be picking up new page creations as well. I assume I need to include something in the Condition and Exclude fields? Or do I need to start writing ECM...
144
Views
0
Likes
3
Answers and Comments
Re: DAM asset default image? Rich_Clem - Adobe Experience Manager
Ah found it, its in,/libs/cq/ui/widgets/themes/default/icons/240x180/page.pngI have temporarily removed this so that is reverts to a smaller image in my search mosaic, as per CQ5.4I have tried to override this by creating the same structure under apps, but that doesn't work. Is there another way of doing this?
83
Views
0
Likes
0
Answers
DAM asset default image? Rich_Clem - Adobe Experience Manager
If a DAM item doesn't have a suitable rendition to display, CQ displays a default icon. Unfortunately in 5.6.1 this image seems to be a lot larger than the version in 5.4.Where is this image defined and can it be modified, over-ridden?Thanks
118
Views
0
Likes
1
Answers and Comments
5.6.1 service pack 2 user login names no longer case insensitive? Rich_Clem - Adobe Experience Manager
I am just testing 5.6.1 service pack 2. We seem to have an issue that when logging into AEM Author, that the user name is no longer case insensitive.I am logging in with an LDAP user. The user ID is stored as upper case in the LDAP. But AEM does initially recognise the user if logging in with the user name in lower case. It creates the user ID in upper case, but then says the username and password are incorrect. If I do put the user name in Upper case it works. Is this a bug or new functionality...
81
Views
0
Likes
1
Answers and Comments
Re: Possible to allow users to move but not delete pages ? Rich_Clem - Adobe Experience Manager
Unless I have misunderstood this does not appear to work. See the attached image. I have a user who is a member of express_default, and express_admin. With the permissions as shown I cannot move or delete. This is in CQ 5.3 but I would have thought this is applicable to any version.[img]permissions.png[/img]
450
Views
0
Likes
0
Answers
Possible to allow users to move but not delete pages ? Rich_Clem - Adobe Experience Manager
Is it possible to set a page permissions up so that a page can be moved by a user but not deleted? I am assuming not, as I guess a move is a copy and a delete.We currently force users to use a workflow to delete pages so that it can stop any deletions above a set folder level, and so we deny delete node and child node.Thanks
1442
Views
0
Likes
3
Answers and Comments
Re: Issue moving CQ5.4 from Java 1.5 to 1.6 Rich_Clem - Adobe Experience Manager
Fixed - Copied the sling.properties from a java 1.6 installed CQ.
99
Views
0
Likes
0
Answers
Issue moving CQ5.4 from Java 1.5 to 1.6 Rich_Clem - Adobe Experience Manager
We have an instance of CQ 5.4 that I am trying to run on java 1.6 instead of java 1.5. This doesn't seems to work though, and we believe there may be a setting that you have to change, that was set when CQ was originally installed, to get it to use the jre-1.6 settings instead. I can see that there are some definitions in the sling.properties file, which seems to list the classes to use. Is there somewhere I need to change CQ so that it uses the jre-1.6 classe definition instead of the jre-1.5 ?...
115
Views
0
Likes
1
Answers and Comments
Delete button greyed out in CQ5.3 after installing feature pack Rich_Clem - Adobe Experience Manager
On one of our development environements for CQ5.3 we have just installed feature pack cq-5.3.0-featurepack-37434-4. Now for some reason we cannot delete pages even as administrator. According to CQ this user should have permissions to do this. Any suggestions? Thanks
77
Views
0
Likes
1
Answers and Comments
Re: Any issues importing a workflow from CQ 5.3 in to AEM 5.6..1 Rich_Clem - Adobe Experience Manager
Sham HC wrote... Should not be issue unless you have customized OOB workflow. After migration follow [1] to force upgrade so that you do not have to worry much. [1] * From crx explorer create/set the /var/upgrade/status/upgradesExecutor.forceUpgrades property to true.* Stop and restart the com.day.cq.cq-upgrades-executor bundle from felix console http://:/system/console/bundles/com.day.cq.cq-upgrades-executor* The log shows upgrades progress* When done, delete the upgradesExecutor.forceUpgrades ...
105
Views
0
Likes
0
Answers
Any issues importing a workflow from CQ 5.3 in to AEM 5.6..1 Rich_Clem - Adobe Experience Manager
I believe the underlying structure of how workflows are stored have been changed from CQ 5.5.We are looking to upgrade a CQ 5.3 instance to 5.6.1. An inplace upgrade would automatically upgrade workflows. But we are having issues getting the inplace upgrade to work and so are looking at migrating to AEM 5.6.1 by packaging up content/apps/etc in 5.3 and importing into 5.6.1Are there any issues with doing this or do we have to create the workflows from scratch?Is there any documentation on how the...
160
Views
0
Likes
2
Answers and Comments
Re: Using Forum component in CQ5.4 Rich_Clem - Adobe Experience Manager
Ah yes extending the component is probably going to be the best route. Looks like we may need to tweak some of the other functionality as well.Cheers
40
Views
0
Likes
0
Answers
Likes given to
Likes from