since ‎08-11-2018
‎11-02-2020
rishabhkrishan
Level 2
Re: Error on quickstart AEM 6.4 rishabhkrishan - Adobe Experience Manager
Hi MartinKSA, I faced the same problem. Here is what I did:Started AEM instance with JDK11Changed the JAVA_HOME to JDK8After this the same error popped up. So I changed the JAVA_HOME back to JDK11 and it worked. Take a look whether have you done the same thing. Thanks
1200
Views
1
Like
0
Answers
Repository Login rishabhkrishan - Adobe Experience Manager
Hi All,I am trying to login into repository using code given in tutorial : How to programmatically access the AEM JCR.On running the main method following stack trace is shown :I have yet not changed any dependencies in pom.xml nor tried installing any JCP API. The port no. I am using is 4504Thanks in advance.
1030
Views
0
Likes
1
Replies
Re: Metadata Extraction rishabhkrishan - Adobe Experience Manager
Thanks man it works.Can you tell me why checking Handler Advance is important ?
677
Views
0
Likes
0
Answers
Re: Metadata Extraction rishabhkrishan - Adobe Experience Manager
Workflow is not terminating and even I have setup a customised log file, there is nothing getting logged.
666
Views
0
Likes
0
Answers
Metadata Extraction rishabhkrishan - Adobe Experience Manager
Hi All,I wanted to set property of a metadata node in /content/dam/emailWorkflow64/asset.jpg/jcr:content/metadata (for example) using workflow. I have made a custom workflow process step and executed it manually inside a workflow model. Its not working please help.I have given payload for workflow model : /content/dam/emailWorkflow64/asset.jpg/jcr:content/metadataHere is code snippet :import javax.jcr.Node;import javax.jcr.PathNotFoundException;import javax.jcr.RepositoryException;import javax.j...
1179
Views
1
Like
5
Answers and Comments
Re: problem in creating custom workflow for sending Emails rishabhkrishan - Adobe Experience Manager
version 3.5.4
973
Views
0
Likes
0
Answers
Re: problem in creating custom workflow for sending Emails rishabhkrishan - Adobe Experience Manager
Hi Ratna,Hey thanks for looking into my problem. I have copied and pasted code given into core POM and parent POM and ran command : mvn -PautoInstallPackage install , it is giving core build error as shown in the screenshot below:It has to do something with the slf4j-api jar file. Please help.
966
Views
0
Likes
0
Answers
problem in creating custom workflow for sending Emails rishabhkrishan - Adobe Experience Manager
Hi, I am using AEM v6.4 and Maven v3.5.4. I have started creating custom workflow for sending email using this tutorial: Adobe Experience Manager Help | Creating an Adobe Experience Manager 6.4 custom workflow step that uses the MessageGatew…The problem is that code given is using the following import for email:import org.apache.commons.mail.Email;import org.apache.commons.mail.EmailException;import org.apache.commons.mail.SimpleEmail;which is showing error in Eclipse. Please help.I have also do...
4721
Views
2
Likes
9
Answers and Comments
Re: Layout mode unavailable rishabhkrishan - Adobe Experience Manager
Yeah, sure. Initially there were two templates in the template folder. I deleted both of them and created one custom template. Is this the reason why layout mode is not showing up ?
673
Views
0
Likes
0
Answers
Re: Layout mode unavailable rishabhkrishan - Adobe Experience Manager
Yeah, problem is layout is not appearing in the dropdown as marked in your reply. For we-retail I am getting it but not for my project. Is it the problem with the archetype command that i have used:mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeGroupId=com.adobe.granite.archetypes -DarchetypeArtifactId=aem-project-archetype -DarchetypeVersion=13 -DarchetypeCatalog=https://repo.adobe.com/nexus/content/groups/public/
676
Views
0
Likes
0
Answers
Re: Layout mode unavailable rishabhkrishan - Adobe Experience Manager
This is the command that I have used for making my project.mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeGroupId=com.adobe.granite.archetypes -DarchetypeArtifactId=aem-project-archetype -DarchetypeVersion=13 -DarchetypeCatalog=https://repo.adobe.com/nexus/content/groups/public/
703
Views
0
Likes
0
Answers
Layout mode unavailable rishabhkrishan - Adobe Experience Manager
I have used a sample archetype to create pages in AEM 6.4. However, I am not able to use the layout feature as it is not appearing in dropdown. What could be its reason ? I have tried looking for it on the web only to fail. Please Help !
1644
Views
0
Likes
9
Answers and Comments
How to use coral ui in making simple form component ? rishabhkrishan - Adobe Experience Manager
I have started with Coral UI and have gone through its documentation. However, I am unable to find the starting point.I have also tried making custom component and pasting coral UI markups given in documentation. Its not showing up properly. For example, I have used following code in my custom component html script: FirstName LastName PhoneNo Rishabh Krishan 9454117031 Krishna Kumar 9545675429 only table is displayed but no hovering. Please Help.
1566
Views
1
Like
6
Answers and Comments
How to use Anchor Button rishabhkrishan - Adobe Experience Manager
How to use AnchorButton component from granite ? I am using AEM 6.4. I want to have link as a button so that author can have different link for different button on pages.I am struggling with how to write content.xml file in eclipse.Please Help.
717
Views
0
Likes
1
Answers and Comments
Eclipse Plugin for AEM 6.4 rishabhkrishan - Adobe Experience Manager
Hi,I am trying to install Eclipse(Oxygen) Plugin for AEM 6.4. I have downloaded such plugin archive from AEM Developer Tools.​ It has downloaded com folder which has many jar files. Now When I am trying to install a new software using eclipse it is asking for installation link. I gave the above installation link but its not working.Please help me, I am stuck here for past 2 hours.
923
Views
0
Likes
3
Answers and Comments
Impersonation failure rishabhkrishan - Adobe Experience Manager
I am using AEM6.4 and logged in using admin acess. While using AEM Security I created a user and from dropdown given in the top-right corner I tried impersonating it as the newly created user. After that I cannnot access anything from my project.Opening the localhost:4502 gives "A custom errorhandler for 404 responses".This is screenshot of my CRXDE Lite
553
Views
0
Likes
2
Answers and Comments
Likes given to
Likes from