Highlighted

Target QA urls not working in Safari

rubyw92148897

27-06-2019

When using Target’s QA urls within Safari the test doesn’t render (specifically on a mac - not tried on mobile), but the same QA urls are working as expected within Chrome, Firefox and Edge.

As a work-around we're having to activate the activity within an IP restricted UAT environment and then QA, as when the activity is activated it renders perfectly fine.

Any ideas what might be the issue?

Replies

Highlighted

surebee

Employee

28-06-2019

Hi rubyw92148897​,

How is the activity URL set up? Is it such that you have to browse multiple pages to reach the activity page?


For example: activity is set up on cart page but you start QAing from the home page, add an item to the cart and then get to the cart page to QA Target activity content delivery?

In some cases, Safari does not seem to "persist" the QA mode when you have to go through different pages to reach the activity URL when testing with the QA URL. In any case, you could open up a Client Care ticket by emailing us at clientcare@adobe.com and we can take a look.

Highlighted

rubyw92148897

30-06-2019

Hi surbgupt​,

I am going directly to the URL that the activity is set up on, sometimes there is a page refresh which is default site behaviour (and not sure why it's happening), but it's the same URL after the refresh too.

Besides the activity being set on a different URL to direct entry, do you know what the cases are that allow or don't allow the QA mode to persist?

I will email support now too, thanks very much for your help!

Highlighted

katiepolo90

15-08-2019

Hey! did you get any response to this? I have found myself having the same issue and i cannot for the life of me figure out why

I am using Safari v12.1 and my QA links work in Chrome, Firefox, IE11 and Edge, but I cannot get them to work in safari

Any help would be appreciated!

gaureshk3014423

21-08-2019

Hi

Activity QA preview links

Activity QA preview links for saved activities might not load if there are too many saved activities in your account. Re-trying the preview links should work. To prevent this from continuing to happen, archive saved activities that are no longer actively used. (TNT-32697)

for more info Known issues and resolved issues might help you.

Check if you fit in above criteria.

Thanks,

Gauresh kodag

Highlighted

surebee

Employee

26-08-2019

Hi rubyw92148897,

Thank you for the info! Did you successfully submit a support ticket with us?

Also, what version of at.js are you using? Some background on how QA links work in  at.js 1.x as compared to at.js 2.x:

In at.js 1.x, QA mode works by storing QA mode related cookies on Target tt.omtrdc.net domain (i.e. third party domain). Safari blocks third party cookies hence QA mode details are lost when navigating from one page to another.

In at.js 2.x, we rely on first party cookies to store QA mode details, so the QA links with at.js 2.x even when navigating between pages should work as expected.

Also, as gaureshk30144236​ ​ mentioned, we do have a known issue with QA links where in if there are too many saved activities on your account, the QA links do not work on initial load but work on a subsequent refresh.

katiepolo90​ hope the above explanation is helpful to you as well, please respond if you have any questions!

Highlighted

BrendanJaffary

09-10-2019

I am using at.js 2x and can't use Activity QA urls on any browser.

I've gone through my entire account and deleted all archived activities and unused criteria/collections/designs. 

Is there any update you can provide us on further findings on your end?

Thanks