Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Target QA urls not working in Safari

Avatar

Avatar
Give Back
Level 2
rubyw92148897
Level 2

Likes

4 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 3
Boost 1
View profile

Avatar
Give Back
Level 2
rubyw92148897
Level 2

Likes

4 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 3
Boost 1
View profile
rubyw92148897
Level 2

27-06-2019

When using Target’s QA urls within Safari the test doesn’t render (specifically on a mac - not tried on mobile), but the same QA urls are working as expected within Chrome, Firefox and Edge.

As a work-around we're having to activate the activity within an IP restricted UAT environment and then QA, as when the activity is activated it renders perfectly fine.

Any ideas what might be the issue?

Replies

Avatar

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile
gaureshk3014423
Level 8

28-06-2019

Hi rubyw92148897​,

May I know which version of Safari browser you are using to check QA URLs?

Thanks,

Gauresh Kodag.

Avatar

Avatar
Give Back
Level 2
rubyw92148897
Level 2

Likes

4 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 3
Boost 1
View profile

Avatar
Give Back
Level 2
rubyw92148897
Level 2

Likes

4 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 3
Boost 1
View profile
rubyw92148897
Level 2

28-06-2019

Hey gaureshk30144236​, I'm using Version 12.1.1.

Avatar

Avatar
Coach
Employee
surebee
Employee

Likes

67 likes

Total Posts

83 posts

Correct Reply

20 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
surebee
Employee

Likes

67 likes

Total Posts

83 posts

Correct Reply

20 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 5
Give Back 3
View profile
surebee
Employee

28-06-2019

Hi rubyw92148897​,

How is the activity URL set up? Is it such that you have to browse multiple pages to reach the activity page?


For example: activity is set up on cart page but you start QAing from the home page, add an item to the cart and then get to the cart page to QA Target activity content delivery?

In some cases, Safari does not seem to "persist" the QA mode when you have to go through different pages to reach the activity URL when testing with the QA URL. In any case, you could open up a Client Care ticket by emailing us at clientcare@adobe.com and we can take a look.

Avatar

Avatar
Give Back
Level 2
rubyw92148897
Level 2

Likes

4 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 3
Boost 1
View profile

Avatar
Give Back
Level 2
rubyw92148897
Level 2

Likes

4 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 3
Boost 1
View profile
rubyw92148897
Level 2

30-06-2019

Hi surbgupt​,

I am going directly to the URL that the activity is set up on, sometimes there is a page refresh which is default site behaviour (and not sure why it's happening), but it's the same URL after the refresh too.

Besides the activity being set on a different URL to direct entry, do you know what the cases are that allow or don't allow the QA mode to persist?

I will email support now too, thanks very much for your help!

Avatar

Avatar
Level 1
katiepolo90
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
katiepolo90
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
katiepolo90
Level 1

15-08-2019

Hey! did you get any response to this? I have found myself having the same issue and i cannot for the life of me figure out why

I am using Safari v12.1 and my QA links work in Chrome, Firefox, IE11 and Edge, but I cannot get them to work in safari

Any help would be appreciated!

Avatar

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile
gaureshk3014423
Level 8

21-08-2019

Hi

Activity QA preview links

Activity QA preview links for saved activities might not load if there are too many saved activities in your account. Re-trying the preview links should work. To prevent this from continuing to happen, archive saved activities that are no longer actively used. (TNT-32697)

for more info Known issues and resolved issues might help you.

Check if you fit in above criteria.

Thanks,

Gauresh kodag

Avatar

Avatar
Coach
Employee
surebee
Employee

Likes

67 likes

Total Posts

83 posts

Correct Reply

20 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
surebee
Employee

Likes

67 likes

Total Posts

83 posts

Correct Reply

20 solutions
Top badges earned
Coach
Contributor
Shape 1
Give Back 5
Give Back 3
View profile
surebee
Employee

26-08-2019

Hi rubyw92148897,

Thank you for the info! Did you successfully submit a support ticket with us?

Also, what version of at.js are you using? Some background on how QA links work in  at.js 1.x as compared to at.js 2.x:

In at.js 1.x, QA mode works by storing QA mode related cookies on Target tt.omtrdc.net domain (i.e. third party domain). Safari blocks third party cookies hence QA mode details are lost when navigating from one page to another.

In at.js 2.x, we rely on first party cookies to store QA mode details, so the QA links with at.js 2.x even when navigating between pages should work as expected.

Also, as gaureshk30144236​ ​ mentioned, we do have a known issue with QA links where in if there are too many saved activities on your account, the QA links do not work on initial load but work on a subsequent refresh.

katiepolo90​ hope the above explanation is helpful to you as well, please respond if you have any questions!

Avatar

Avatar
Give Back 5
Level 2
BrendanJaffary
Level 2

Likes

9 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 1
Boost 5
View profile

Avatar
Give Back 5
Level 2
BrendanJaffary
Level 2

Likes

9 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 1
Boost 5
View profile
BrendanJaffary
Level 2

09-10-2019

I am using at.js 2x and can't use Activity QA urls on any browser.

I've gone through my entire account and deleted all archived activities and unused criteria/collections/designs. 

Is there any update you can provide us on further findings on your end?

Thanks