Highlighted

mbox is returning the experience code, but experience not rendering

cqvoyager 31-07-2018

Hello Team,


I set up a basic experience targeting from with in the AEM.

I see that experiences are coming in the response of mboxes. But those mbox responses are not being rendered for some reason. I verified on Chrome and Firefox and see the separate experiences loading up in the network tab.

Not sure what I need to do to enable that rendering of responses. Any help is highly appreciated.

Screen Shot 2018-07-30 at 6.56.22 PM.pngScreen Shot 2018-07-30 at 6.56.42 PM.png

Best Regards,

Durga

Replies

Highlighted
Joshua_Eisikovi
Employee
03-08-2018

Hi Durga,

Are you able to provide a little more insight on the issue above?

i.e

[1] Activity URL?

[2] What content changes are you expecting once am mbox is firing.

Thanks

Joshua

Highlighted
karand53490614 09-08-2018

HI Durga,

You can check from the mbox Trace if you are falling in to any of the created segment.

For mbox Trace please go to Troubleshooting Content Delivery

Hope this will help.

Regards,

Karan

Highlighted
Shruthi_N
Employee
22-10-2018

Hi Durga, if you are using at.js could you try appending mboxDebug=console to the url and then refreshing the url with the console in the developer tools open? This would tell you if there are any selector issues because of which target is unable to apply the changes on the page even though the response contains the experience .

Eg. www.test123.com?mboxDebug=console (If you are on mbox.js then use _AT_Debug=console)