Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

problem with creat PDF in adminui.

Avatar

Level 2

Hi,

   I have just install live cycle Pdf generator. installation log shows installation is successful.I have configure The things which I had to do,like installing

   windows office(2007),acrobat reader,change UAC.

 

now  when I want to convert some word document(.doc) to pdf ,It fails to convert,It shows the following messege:

Error Code:1000
Error Message:

Error message from the primary converter:
ALC-PDG-001-000-Conversion of the input file failed because of an exception.
An unexpected exception while resolving a new connection to an Adobe Service.

Error message from the fallback converter:
ALC-PDG-011-030-Submitted OpenOffice Document could not be converted to PDF. Either OpenOffice is not installed on this system or environment variable OpenOffice_PATH is not set to correct path. Please set OpenOffice_PATH environment variable to the <OpenOffice_Installation_Dir> on the server (e.g C:\Program Files\OpenOffice.org 3.0) and then restart the server.

can any body trace the problem ? what I have to do to get successful convertion?

Thanking you.

Barun Barik

3 Replies

Avatar

Level 3

I think you can try to disselect the "" in the

Home > Services >LiveCycle PDF Generator ES2 > File Type Settings > Edit File Type Setting:

Microsoft Word

Of cause the standard and the defaults in the LC can not be modified directly , you can modify one of them and save it as you need , then disselect the "" , and the same setting for other microsoft office types , then try again .

Good luck with you !

Avatar

Level 1

Hi,

If you still have the problem, please check the path of JAVA environment variable.

Thanks,

KazSakai

Avatar

Level 2

Hi,

   right now there is no problem..

.path of java environment variable is ok...

I was using turnkey installation.I dont think in case of turnkey  installation we need to set java environment variable ...

If u have 64bit java then u have to install additional 32bit java therefore you have to set environment variable for that 32 bit of java.

I think I had some configuration problem..after reinstallation this problem has been resolved.

Thanking you.

Barun Barik