Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Player 10.1 and Air using Compatibility Mode

Avatar

Level 3

This is related to post at http://forums.adobe.com/message/2933137#2933137, but, thought I should start another since that one is marked answered.

I'm having a similar issue with an Air app, but, I am using 4.1 SDK (and LCCS 10.1 swc), but still getting the same error regarding GroupSpecifier (pasted below).

I have an Air app project and related web app project, which both use a library project (ARSystemLib in the trace below).  The library project is using 4.1 SDK, and has the Flex 3 compatibility mode turned on, along with 10.1.0 set as "use a specific version" under "Flash Player Options".  The Air project is also using 4.1 SDK and Flex 3 compatibility, along with the compiler option "-target-player=10.1.0".

For the web app, I had to remove the "Use a specific version" of 10.1.0 for it to compile ( was getting many "Classes must not be nested", which seems to be a difficult issue to fix after much research on others getting this message).

I'm okay with the web version not using 10.1 for p2p, but, critically need this for the Air version.  I'm hoping it's not the "Compatibility" mode setting, as reworking the app without is a huge undertaking.

Thanks,

David

VerifyError: Error #1014: Class flash.net::GroupSpecifier could not be found.

at com.adobe.rtc.session::ConnectSessionContainer()[/Users/arun/Work/aponnusa_theoden.corp.adobe.com_1666/depot/branches/connect/1010/cocomoPlayer10.1/src/com/adobe/rtc/session/ConnectSessionContainer.as:112]
at com.ssc.compo

1 Accepted Solution

Avatar

Correct answer by
Employee
Hi David,
Apologies for the delayed response. I am guessing you will have to update the namespace in your <PROJECTNAME>-app.xml file under src of your project.
Your name space should be 2.0 or greater.
Its possible that your app has namespace like -
<application xmlns="http://ns.adobe.com/air/application/1.5"> , 
but it should be
<application xmlns="http://ns.adobe.com/air/application/2.0">
Also other options is to add -target-player=10.1.0 to your flex compiler options [additional compiler arguments]
Thanks
Arun

View solution in original post

6 Replies

Avatar

Employee

Can you send the exact version of FlashBuilder you are using and a screenshot of the player option dialog ? Thanks!

Avatar

Employee

As Raff mentioned, You might be using player10.1 src/swc and your

project might be compiling against player 9.

Thanks

Arun

Avatar

Level 3

Here's the print screens, let me know if you can't read and I'll PM them to you.

FB4-Version.png

AirProject-Settings.png

LibProject-Settings.png

Avatar

Level 3

Also, I'm using Eclipse 3.5.2 with FB 4 plugin.

Avatar

Correct answer by
Employee
Hi David,
Apologies for the delayed response. I am guessing you will have to update the namespace in your <PROJECTNAME>-app.xml file under src of your project.
Your name space should be 2.0 or greater.
Its possible that your app has namespace like -
<application xmlns="http://ns.adobe.com/air/application/1.5"> , 
but it should be
<application xmlns="http://ns.adobe.com/air/application/2.0">
Also other options is to add -target-player=10.1.0 to your flex compiler options [additional compiler arguments]
Thanks
Arun

Avatar

Level 3

Arun:

Thanks, updating the desciptor to 2.0 did the trick!

Regards,

David