Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Opening XFA dynamix form in somethign other then adobe reader

Rien_vd_Voorden
Level 2
Level 2

Hi,

we currently are having issues with people not using adobe reader as their standard program to view pdf-files.

Most of them use NitroPDF. The problem is that this viewer doesnt support XFA-forms.

Is there a way to force, for example by using javascript, them to use adobe reader? (setting adobe reader as the standrad reader in the OS is not an option)

Kind regards,

Rien

1 Accepted Solution
_Sid_
Correct answer by
Level 3
Level 3

You can;t force them, but you can try to educate them.

basically if a form cannot be viewed in non Adobe viewers/readers, it would still show a page (a.k.a pagezero) which shows a default message.

You can customize that page to inform users that XFA forms dont work in other readers.

customization help available here : AEM 6.0 Forms Help | Changing Page Zero content in Designer

View solution in original post

11 Replies
_Sid_
Correct answer by
Level 3
Level 3

You can;t force them, but you can try to educate them.

basically if a form cannot be viewed in non Adobe viewers/readers, it would still show a page (a.k.a pagezero) which shows a default message.

You can customize that page to inform users that XFA forms dont work in other readers.

customization help available here : AEM 6.0 Forms Help | Changing Page Zero content in Designer

View solution in original post

Rien_vd_Voorden
Level 2
Level 2

~Sid~,

thanks for the reply. Changing the default page sounds like an good option. Thanks again.

Kind regards,

Rien

jnicholas330
Level 7
Level 7

Can anyone with an ES4 license get this feature pack, or is AEM license required?

radzmar
Level 10
Level 10

@~Sid~: What happens to that page when you add Reader Extension with Acrobat?

I believe it will be replaced by the dafault Please wait...-message, isn't it?

_Sid_
Level 3
Level 3

radzmar‌ - interesting question. I never actually tried that.

The LiveCycle server has it's own reader extensions service, and i know that does not affect the pagezerocontent property.

In theory even if you do the reader extension from Acrobat or LC server, that is simply adding some metadata and repackaging the PDF.

I would expect that it shouldn't fiddle with this property. Do you have any new observations in that regard ?

i recall that in one of the versions of LC, if you apply this property , and then close and open the form again in designer, this variable is not visible anymore.

Although it's still in effect, it just doesn;t show on the UI, i hope that is not the case. They most likely have this fixed in the latest AEM Forms LC designer

radzmar
Level 10
Level 10

I did a test in AEM Forms Designer 6.1 and got following results.

Adding a _pagezerocontent variable to the forms properties does nothing useful at my end.

When I save the file as a dynamic XFA form I still get the default message:

And when I save as static XFA form, I get a blank page instead.

_Sid_
Level 3
Level 3

I'm pretty sure this was working in the AEM 6.0 FP1 release when i tested it, and i doubt if there have been any major changes since then.

can you validate of the value of the pagezerocontent variable is actually a valid rich text as specified on the page zero documentation page

?.. try starting off with the default value block and make minor changes to see if that works...

for eg: the below pasted

<body xmlns="http://www.w3.org/1999/xhtml" xmlns:xfa="http://www.xfa.org/schema/xfa-data/1.0/"><p style="font-family:'Times';font-size:12pt;letter-spacing:0in"><span style="xfa-spacerun:yes"> </span></p><p style="font-family:'Times';font-size:12pt;letter-spacing:0in">THIS IS A CUSTOM MESSAGE, TO CHECK WHETHER THE PAGEZEROCONTENT VARIABLE WORKS OR NOT <span style="xfa-spacerun:yes"> </span>http://www.adobe.com/go/reader_download.</p><p style="font-family:'Times';font-size:12pt;letter-spacing:0in"><span style="xfa-spacerun:yes"> </span></p><p style="font-family:'Times';font-size:12pt;letter-spacing:0in">For more assistance with Adobe Reader visit <span style="xfa-spacerun:yes"> </span>http://www.adobe.com/go/acrreader.</p></body>


also, try to clear your browser cache completely, or rename the PDF, since the same path and file name might prompt the browser to pick the display page from cache.

radzmar
Level 10
Level 10

Hi ~Sid~.

The solution doesn't work for me.
Can you send me a sample form where you have replaced the message successfully?

_Sid_
Level 3
Level 3

You will have to make sure that your version of designer is either AEM Forms 6.0 Fp1 or more recent than that.

I believe this does not work on ES4 or previous versions.

ludovic_combaul
Level 1
Level 1

It doesn't work with Designer 11.0.0 but it works with Designer ES4 11.0.1

Brian3_14
Level 3
Level 3

Hey Radz and all:

Did you ever get a response/find a solution regarding the custom _pagezerocontent disappearing from an XFA-based PDF once it was reader extended?

Been messing around all day with it and not having any luck.

Tried updating LC to Service Pack one - which does allow for the _pagezerocontent - but once reader extended, we're back to the "Please Wait..."

Ugh.  Thought I was rid of that damn confusing default language.

B