Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

IBMFileNetContentRepositoryConnector fails to start

joels999
Level 1
Level 1

All,

We have an Adobe livecycle server running for many years.  After a crash/reboot... we started the server up and found that the IBMFileNetContentRepositoryConnector-1.0 no longer starts as seen in the adobe livecycle adminui.

When I try and restart it, it fails.  I was able to turn on trace debug and see the following error:

[Searching resource in parent ]com/adobe/filenetconnector/admin/adminMessages.properties

[6/28/19 14:00:58:026 MDT] 00000069 IBMFnetDSCSer E 416:null  ServiceName IBMFileNetContentRepositoryConnectorfailed to start

[6/28/19 14:00:58:026 MDT] 00000069 IBMFnetDSCSer E 416:null  Invalid Configuration Data. Please configure the correct data through adminui

[6/28/19 14:00:58:026 MDT] 00000069 IBMFnetDSCSer E 416:null  com.adobe.filenetconnector.config.ECMConfigException

        at com.adobe.livecycle.filenetservice.service.impl.FilenetProviderServiceImpl.testCEConnection(FilenetProviderServiceImpl.java:1940)

        at com.adobe.livecycle.filenetservice.service.impl.IBMFnetDSCServiceLifeCycleImpl$SessionChecker.run(IBMFnetDSCServiceLifeCycleImpl.java:46)

[6/28/19 14:00:58:027 MDT] 00000069 LocalExceptio E   CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "doRequiresNew" on bean "BeanId(LiveCycleES4#adobe-dscf.jar#EjbTransactionCMTAdapter, null)". Exception data: ALC-DSC-099-000: com.adobe.idp.dsc.DSCRuntimeException: java.lang.Exception: Configuration Information used - cemp:http://fss-pcemp.gwl.com:80/wsi/FNCEWS40MTOM?jaasConfigurationName=FileNetP8WSI, 0, Symmetric, /usr/local/apps/adobe/FileNet/Authentication/UTCryptoKeyFile.properties, PROD_BPI_OS, P8AdmProd

        at com.adobe.livecycle.filenetservice.service.impl.IBMFnetDSCServiceLifeCycleImpl.onStart(IBMFnetDSCServiceLifeCycleImpl.java:257)

        at com.adobe.idp.dsc.registry.service.impl.ServiceRegistryImpl$31.doInTransaction(ServiceRegistryImpl.java:1941)

1. I verified connectivity to the server, and the url parameters, plus username/password.

2. I confirmed no changes were made to the server

3. When I attempt to update the Configuraiton data via the adobe adminui... and hit save... nothing happens... It does not take my changes.  I suspect some of the websphere files could be corrupted due to the crash/reboot.

Any help would be great.

Thanks

1 Accepted Solution
mak4753
Correct answer by
Level 2
Level 2

The issue was resolved by restoring a database backup.

View solution in original post

0 Replies
mak4753
Correct answer by
Level 2
Level 2

The issue was resolved by restoring a database backup.

View solution in original post