Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

How do I fix this problem?

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

I have a lot of data in one column, and when i compy and paste from excel, it overflows like the picture

Form.JPG

Accepted Solutions (0)

Answers (12)

Answers (12)

Avatar

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile
Niall_O_Donovan
Level 10

25-01-2012

See here: http://forums.adobe.com/message/4163164#4163164.

Testing links...

Message was edited by: Niall O\'Donovan

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

Niall,

I have created a new form with your solution and here are my results:

Good news, is that it may not be corrupted...

When the object is just a standard text_field that is not in a table subform, i am able to access the "allow page breaks within content" option in the object field selection. However, when I put the text_field into a table, this "allow page breaks within content" check box is grayed out and there is nothing i can do to bring it back, even changing all the settings that you spoke about earlier (exactly the problem my initial form had).

Am i not allowed to have an expanding table in a form then?

Thanks Niall

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

Hmm I was hoping you had something under your sleeve. I'll give that a try and let you know how it works.

Something tells me that it is corrupted because I also have a problem when someone submits my forms and I open them up. All the fields are hidden.

Avatar

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile
Niall_O_Donovan
Level 10

24-01-2012

Well that just does not make sense...

...Check that all containers/subforms, from the Row right up to the page in the hierarchy allow content breaks.

To be honest that should/will work. I am wondering if the object is corrupted. Can you just try a new blank form and add a new table with the above settings.

Lastly, check the Warnings tab and see if you have set the Target Version of the form (File > Form Properties > Defaults), too low.

Niall

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

Niall,

Yes it does make sense, and I am really appreciative of all of your advice, however, this too has been already set. I have allowed page breaks in content for all my rows and tables. The problem still persists...

Avatar

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile
Niall_O_Donovan
Level 10

24-01-2012

Hi,

If you are using a Table object, then select the Row and allow that to break content. Also do the same with the Table object.

Make sense?

Niall

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

This is very interesting,

My textfields are in a table, so i am not sure that makes a difference or not but what is interesting is that the allow page breaks within content is grayed out in my textfield settings. see image

Text.JPG

Avatar

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile
Niall_O_Donovan
Level 10

24-01-2012

Hi,

Yes, that is correct. For completeness here are the settings for the page:

Flowed01.png  Flowed02.png

And here for the textfield:

Flowed03.png  Flowed04.png

Also make sure the form is saved as a Dynamic XML Form (but I am sure that it already is).

Niall

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

Those are my settings. Are they not correct?Flow.JPG

Avatar

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile
Niall_O_Donovan
Level 10

24-01-2012

Hi,

If you select the page in the hierarchy and go to the Object > Subform palette, make sure that the "Allow page breaks in content" is ticked. See example 4 in the PDF linked above.

Hope that helps,

Niall

Avatar

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
kmarch3381
Level 1

Likes

0 likes

Total Posts

25 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
kmarch3381
Level 1

24-01-2012

Could it be something else? Because my page IS set to flowed.

Avatar

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 10
Niall_O_Donovan
Level 10

Likes

646 likes

Total Posts

4,352 posts

Correct Reply

786 solutions
Top badges earned
Validate 1
Boost 500
Boost 50
Boost 5
Boost 3
View profile
Niall_O_Donovan
Level 10

24-01-2012

Hi,

While you have set the field to expand to match the amount of data in the field, your page is not set to flowed layout and to Allow content to break over pages.

Have a look at this example for making fields dynamic: http://assure.ly/g80MVY.

Hope that helps,

Niall