Data Connection to certificated wsdl not returning data

jeanetter358457 30-01-2020

I am using workbench v 6.4.  I have a dataconnection that calls a wcf service wsdl that requires a digital certificate, but it is not returing the data that I can tell and no error is being thrown.  The certificate has been loaded on the server and brings data back via a process I've created, so I know the call to the wsdl works. 

<FindTrainingSiteResult>
<TrainingSite>
<City>CityName</City>
<State>StateName</State>
<Name>TrainingSiteName</Name>
<CredentialType>CType</CredentialType>
</TrainingSite>
<TrainingSite>
<City>CityName</City>
<State>StateName</State>
<Name>TrainingSiteName</Name>
<CredentialType>CType</CredentialType>
</TrainingSite>
</FindTrainingSiteResult>
</FindTrainingSiteResponse>

I want to make the call via the data connection without submitting the form. 

I have succeeded doing a similar action with another data connection calling a web service but that one doesn't require a certificate.

So can  this be  done via a process without submitting the form or is there another way with the dataconnection?

Mark Solution

Are these answers useful?
Help other community members by marking useful answers as accepted.

Accepted Solutions (0)

Answers (2)

Answers (2)

Mayank_Gandhi
Employee
31-01-2020

When you are making an external call to WS, you first send request from workbench to server and server then send to the endpoint hosting WS. Make sure the cert is loaded on workbench side as well. 

 

Easy test will be to use soapUI and check the connection first.