Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new

Learn more

View all

Sign in to view all badges

"Software Failure"

Not applicable
Hi all.

I've recently found a new error that comes up when attempting to import data into a form from a button using on the "click" event.

It doesn't seem to matter whether I'm trying to import xml or xdp data it always does the same thing. I get the prompt to select the file and then it thinks a bit and then I get the error "Software Failure". that's it. No numbers or codes or anything else.

I've used this script on other forms without this happening... not sure what I did on this one.

Oh, and it doesn't do it if I import data from the File menu rather than using the button.

Does this sound familiar to anyone?

7 Replies
Not applicable
Hi, I have exactly the same problem. Any ideas out there?


Not applicable
I am not able to re-produce the problem. Can you send your form with the xml data file to ? I 'd like to take a look at them.
Not applicable
I had this problem with a form. It turned out that I had "xfa.form.recalculate(1)" in the Calculate section of a field. I changed it to specifically recalculate just the field I needed, and all worked OK.

I was only doing this with importing via the menu.

Hope this helps.
Not applicable
I finally figured out what was causing it (thanks Jimmy Pham for pointing me in the right direction!).

Aparently Designer doesn't like fillable fields on the master pages -particularly any fillable fields with scripting on them. My form has multiple Master Pages which in and of itself wasn't a problem. However, the 'Page # of #' fields and the single address field that repeated on all the different Master Pages(and that was set to call a form variable for it's value) were a problem.

Once I removed these from the Master Pages and reformatted my body pages to be able to handle the data, all was well -no more 'Software Failure' error message.
Not applicable

I experience the same errormessage at the exact same point ( It's quite frustrating since it doesn't give any directions where there might be a problem. After reading this thread I deleted the page n of m field, so there are no more fillable fields in te master page. I haven't used the xfa.form.recalculate(1) action, so that wouldn't make any difference. Jimmy Pham, do you have any more smart tricks at your hand?

best regards,

Not applicable

I found the failure. For some reason the form would not accept a formscalc script that made the value of a field today's date and time.

I changed it to JS and it worked fine.

Level 7
Level 7

Super late to this party, but it seems that you will get this error if your input XML is UTF-16. I.e.

<?xml version="1.0" encoding="utf-16"?>

Once I changed it to utf-8 this issue went away. Using Acrobat XI Pro.