Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Failure starting JBoss Server during Express Configuration


Not applicable
Express configuration is failing with the message not able to start JBoss server. I can manually start the JBoss server w/o errors. Here's the message detail:<br /><br />[2007-06-09 15:07:38,343], INFO , Thread-48, com.adobe.livecycle.lcm.feature.deployment.DeployEARsDialog, Progress: [68%, Starting service JBoss for Adobe LiveCycle ES v8.0]<br />[2007-06-09 15:07:38,343], FINE , Thread-48, com.adobe.livecycle.lcm.util.ServiceUtils, Running: net start "JBoss for Adobe LiveCycle ES v8.0"<br />[2007-06-09 15:07:38,953], FINE , Thread-48, com.adobe.livecycle.lcm.util.ServiceUtils, Service started or not found [2]<br />[2007-06-09 15:07:38,953], SEVERE , Thread-48, com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask, Task failed<br />com.adobe.livecycle.cdv.CDVException[ALC-LCM-999-032]: Service startup failed for: JBoss for Adobe LiveCycle ES v8.0.<br /> at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.ensureServiceRunning(<br /> at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.turnkeyDeployFiles(<br /> at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.turnkeyDeployLFSs(<br /> at com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask$ActualTask.<init>(<br /> at com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask$1.construct(<br /> at com.adobe.livecycle.lcm.core.tasks.SwingWorker$<br /> at
15 Replies


Not applicable
I had a similar problem, are you trying to install PDF Generator also?

When I removed PDF Generator from the list for deploying components everything worked just fine...


Not applicable
Thanks for the reply, but that didn't solve my proble. I even tried running configuration manually and turned off every service except for the forms service, and still have the issue not being able to start the jboss server.


Not applicable
Can you try starting the service from command line using:

> net start "JBoss for Adobe LiveCycle ES v8.0"


Not applicable
Hi Kim,

Can you share the steps/environment settings you've used to make ES running?

Many thanks.


Level 4
In addition to trying net start "JBoss for Adobe LiveCycle ES v8.0" can you also try;

sc query "JBoss for Adobe LiveCycle ES v8.0" to query the status of the service.


starting the service form the windows service panel


Not applicable
Try to switch the user for that service. Switch it to "local system account" in the "log on" tab. The service does start then.

Another option appears to be this:

Goto Control Panel, Administrative Tools, Local Security Settings

Then drill down to Security Settings, Local Policies, User Rights Assignment, where you take the key "Log on as a service"

You must add your user account, or the Administrator user as an account there to start the service. Then you should not have to alter the "local system account" because this may interfere with PDF Generator that must have a "normal" user account.



Not applicable
It doesn't even appear on my system that the ES installation wizard intalled the JBoss service. Any idea how this would come about? I received no errors or the like during install.



Not applicable
I'm trying to configure LiveCycle ES 'preview' version and getting a very similar error when clicking the 'deploy' button on the wizard page that deals with JBoss config EAR file deployment:

[2007-08-17 14:01:56,328], SEVERE , Thread-5,

ployment.DeployEARsTask, Task failed

com.adobe.livecycle.cdv.CDVException[ALC-LCM-999-010]: The following ports requi

red by JBoss for Adobe LiveCycle ES v8.0 are still in use 1098.

The error seems to be saying port 1098 is in use which is causing the deploy process to fail as it checks all the available ports. I've tried editing every single xml config file I can find that contains "1098" in it (changing it to 1100 instead). This is because my Win XP box is running instances of CLI.exe (which is the ATI Catalyst Control Centre - the graphics card controller) which itself seems to hog port 1098 and there's no way I can stop it doing that.

Any clues anyone?


Level 10
This usually happens when the service "JBoss for Adobe LiveCycle" service is trying to start and can't start properly.

Change the account the service is running under under windows services and you should be fine.



Not applicable
Hi Everyone,

I m really frustrated with this issue. I am trying to install Adobe LiveCycle ES Update 1 trial version JBOSS turnkey option.

The rest already know it. It does not work!!

There is no way I get passed the "Error[ALC-LCM-999-032], with a Failed on 'Starting service JBoss For Adobe LiveCycle ES'. Service startup failed for: JBoss for Adobe LivecycelES."

This error happens during the config stage of the installation. I tried pretty much anything I could find out there as potential solution to the problem. I even tried it in a brand new machine whit pretty much nothing in it: so no possible port conflict (by the way I tried starting jboss directly from the cmd line under Adobe 8.2 dir and it starts fine. i.e: Only the service is busted!!!), tried changing the local policy right and Allow Logon as a service, tried changing the account the service is running under, to no avail.

I tried installing it in machines with Win XP, SP2, JavaSDK1.5_017

Also, tried installing it in machines with Win Server03 SP2 Standard Edition x64. Same JDK.

I have tried 8 machines. 1 worked ! (same OS as the others...or so it looked like until I tried running localhost:8080/stat. /adminui works...anyways)

I am obviously missing something !

Can you please help! Thank you.


Not applicable
Seems a long time since you guys had this problem so I hope you can help me

I'm on XP service pack 3 trying to install LiveCycle 8.21. Having the same problem

Error[ALC-LCM-999-032], with a Failed on 'Starting service JBoss For Adobe LiveCycle ES'. Service startup failed for: JBoss for Adobe LivecycelES."

Have done the following

1. Can start JBoss manually using the run.bat

2. Have checked the "log on as a service" in the group policy has my user added - this is the administrator account

3. Checked that the service logs on with the local system account.

4. Delselected the PDF generator

None of these fix the problem

When I try to manually start the "JBoss For Adobe LiveCycle ES" service from the services control I get the message

The JBoss For Adobe LiveCycle ES service on local computer started then stopped.

When I try to start from the command line I get this

net start "JBoss for Adobe LiveCycle ES"

The JBoss for Adobe LiveCycle ES service is starting.

The JBoss for Adobe LiveCycle ES service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

Then when i check if the service is running I get this

sc query "JBoss for Adobe LiveCycle ES"

SERVICE_NAME: JBoss for Adobe LiveCycle ES

TYPE : 110 WIN32_OWN_PROCESS (interactive)



WIN32_EXIT_CODE : 0 (0x0)




Not really sure where to go now


Level 4
The actual error would be printed in the JBoss logs which can be found at <lc home>\jboss\server\all\log. Try pasting the content of server.log and then only the actual error can be determined


Not applicable
The log is in the C:\Adobe\LiveCycle8.2\jboss\server\default\log directory not the one you specified but I guess thats not important.

When I use run.bat I get a huge log file - 605k. However when I use LiveCycle and I get the

Error[ALC-LCM-999-032], with a Failed on 'Starting service JBoss For Adobe LiveCycle ES'. Service startup failed for: JBoss for Adobe LivecycelES

There is no log of any kind of error. I deleted the contents of the log and it doesn't add anything. Rerunning the run.bat reproduces the same log as before.

There is also a boot.log. When I use run.bat this is filled with 62k however livecyle leads to nothing being printed here.

I dont want to put the whole log here as its 100's of lines long. I looked through them and all the statements are info or debug apart from near the very end of the server.log where there are 2 exceptions because sql cant make tables as they already exist.

java.sql.SQLException: Table already exists: JMS_MESSAGES in statement [CREATE CACHED TABLE JMS_MESSAGES]

java.sql.SQLException: Table already exists: JMS_TRANSACTIONS in statement [CREATE CACHED TABLE JMS_TRANSACTIONS]

The key seems to be the fact that the service cant be started at all but how can I find out why it cant be started. What I really need is an error message.


Not applicable
Ok made a little progress after doing some research. Jboss has different configurations it can start in. When you type run.bat it selects the default config. There is a directory for each config with different settings and logs etc. For me I can run the default config but when I use the all config it dies.

This produces a huge log and I'm not sure where to look in the log. However here is the section where JBOSS shuts down and the proceding 20 or so lines. Hope this will give someone an idea of what the problem is.

2009-03-09 14:55:27,312 ERROR [org.apache.axis.configuration.EngineConfigurationFactoryServlet] Unable to find config file. Creating new servlet engine config file: /WEB-INF/server-config.wsdd

2009-03-09 14:55:27,765 INFO [org.jboss.deployment.EARDeployer] Started J2EE application: file:/C:/Adobe/LiveCycle8.2/jboss/server/all/deploy/Lava_Adobe.ear

2009-03-09 14:55:30,265 INFO [org.jboss.deployment.EARDeployer] Init J2EE application: file:/C:/Adobe/LiveCycle8.2/jboss/server/all/deploy/adobe-contentservices.ear

2009-03-09 14:55:55,765 INFO [org.jboss.web.tomcat.tc5.TomcatDeployer] deploy, ctxPath=/contentspace, warUrl=.../tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/

2009-03-09 14:55:56,640 INFO [org.apache.myfaces.config.FacesConfigurator] Reading standard config org/apache/myfaces/resource/standard-faces-config.xml

2009-03-09 14:55:58,234 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config jar:file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/authentication-service.jar!/META-INF/faces-config.xml

2009-03-09 14:55:58,250 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config jar:file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/lc-native-repository-ref.jar!/META-INF/faces-config.xml

2009-03-09 14:55:58,265 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config jar:file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/lc-transformation-service.jar!/META-INF/faces-config.xml

2009-03-09 14:55:58,281 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config jar:file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/process_samples.jar!/META-INF/faces-config.xml

2009-03-09 14:55:58,312 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config jar:file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/rightsmanagement-action.jar!/META-INF/faces-config.xml

2009-03-09 14:55:58,343 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config jar:file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/workspace-integration.jar!/META-INF/faces-config.xml

2009-03-09 14:55:58,390 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-app.xml

2009-03-09 14:55:58,437 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-beans.xml

2009-03-09 14:55:58,640 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-navigation.xml

2009-03-09 14:55:58,703 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-common.xml

2009-03-09 14:55:58,750 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-repo.xml

2009-03-09 14:55:58,812 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-wcm.xml

2009-03-09 14:55:58,859 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-custom.xml

2009-03-09 14:55:58,906 INFO [org.apache.myfaces.config.FacesConfigurator] Reading config /WEB-INF/faces-config-enterprise.xml

2009-03-09 14:55:59,062 INFO [org.apache.myfaces.config.FacesConfigurator] Starting up MyFaces-package : myfaces-api in version : 1.1.5 from path : file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/myfaces-api-1.1.5.jar

2009-03-09 14:55:59,062 INFO [org.apache.myfaces.config.FacesConfigurator] Starting up MyFaces-package : myfaces-impl in version : 1.1.5 from path : file:/C:/Adobe/LiveCycle8.2/jboss/server/all/tmp/deploy/tmp1462068917909607306adobe-contentservices.ear-contents/contentservices-exp.war/WEB-INF/lib/myfaces-impl-1.1.5.jar

2009-03-09 14:55:59,062 INFO [org.apache.myfaces.config.FacesConfigurator] MyFaces-package : tomahawk-sandbox not found.

2009-03-09 14:55:59,062 INFO [org.apache.myfaces.config.FacesConfigurator] MyFaces-package : tomahawk not found.

2009-03-09 14:56:00,125 INFO [org.apache.myfaces.config.FacesConfigurator] Serialization provider : class org.apache.myfaces.shared_impl.util.serial.DefaultSerialFactory

2009-03-09 14:56:00,359 INFO [org.apache.myfaces.webapp.StartupServletContextListener] ServletContext 'C:\Adobe\LiveCycle8.2\jboss\server\all\.\tmp\deploy\tmp1462068917909607306adobe-contentservices.ear-contents\contentservices-exp.war\' initialized.

2009-03-09 14:56:00,437 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/contentspace]] Loading Spring root WebApplicationContext

2009-03-09 14:56:13,765 INFO [org.jboss.system.server.Server] Runtime shutdown hook called, forceHalt: true

2009-03-09 14:56:13,765 INFO [org.jboss.system.server.Server] JBoss SHUTDOWN: Undeploying all packages