Highlighted

Problem with subform set

Avatar

27-08-2008

Hi all ,



I am facing a problem with subform set. When i use two subform sets with same set of conditions in a form, only the first subform set works while the second one does nothing. Did any of you faced the same problem ? If so Please let me know the solution you came up with. Thanks.



SrPrabhu

Replies

Highlighted

Avatar

28-08-2008

I use several subforms in my PDF, so shouldn't be a problem. Do you have any more specifics of the problem?
Highlighted

Avatar

Avatar

radzmar

MVP

Total Posts

2.6K

Likes

387

Correct Answer

485

Avatar

radzmar

MVP

Total Posts

2.6K

Likes

387

Correct Answer

485
radzmar
MVP

28-08-2008

Hello,



I'm have the same problem but with checkboxes when I use several instances of a subform.

Allthough the checkboxes are set to "global" and have the same naming!

As I mark them, only the checkboxes in the first instance get marked.

The ones in the other instance of the subform are still blank.



Untill now, I didn't find the reason or an solution for this problem, cause text fields etc. are working fine.
Highlighted

Avatar

29-08-2008

Hi scott,

The problem is with subform set and not subform. In subform set, we can give conditions to make only one subform visible at a time that satisfies the condition. First create a subform set having more than one subform. Now apply the conditions to that subform set. Check if it works. I m sure it wil work. Now just make a duplicate copy of the same subform set. Place it in the same form so that now two subform sets are available. Now preview the form. U wil fine only one subform set working and the other one doesnt.

We can use any number of subform set within a form. If different conditions are applied to each subform set , it works fine.



i wonder now wat wud u do in case if we are in need of two subformset having the same condition in a form ?



Thanks,

Sr Prabhu