Highlighted

First ok, second stall - Third ok, fourth stall - Fifth ok, sixth stall

Sedat_Reyhan

17-08-2008

Hello,



Platform: clustered websphere, SQL server 2005

Version: 8.2.1



When I invoke the process within Workbench fist time, it runs successfully. When i invoke second time the render pdf operation stalls with render exception..and it goes on like this..



Is it because of clustered environment? Also i get systemOut log first from Server1, second from Server2.



It happens even if i change and save the process between two invokes.



Could you advice?



Sedat,

Replies

Highlighted

Sedat_Reyhan

18-08-2008

Jasmin,



I think it was an error related to the second cluster node. I closed the second node and no such problem. And workbench is really faster now 🙂



But i have another error. I followed your suggestions regarding "renderPDfform".



[8/18/08 18:09:22:003 EEST] 0000014a FormServer E com.adobe.formServer.FormServer dumpLog xmldata: XML document structures must start and end within the same entity., cause: XML document structures must start and end within the same entity.



Thanks Jasmin

Sedat
Highlighted

Sedat_Reyhan

18-08-2008

But how can i check it? I have an xdp file and a schema embeded. How can i validate the XML that i get from:

/process_data/ServerInstallationControlForm/object/data ? (form is xfa)



Thank you

Sedat,
Highlighted

Sedat_Reyhan

18-08-2008

I tried to validate the XML and validator found an error like that:<br /><br />Line File name: Nonexistent <br />3 Column: 125 <br /> Error: Can not find declaration of element 'xdp:xdp'. <br /> Error Position: ...Stamp="2008-08-19T05:24:04Z" uuid="739066e1-62a8-4491-9bc8-293d69c06707"> <br /><br />XDP Form's XML:<br /><br /><?xml version="1.0" encoding="UTF-8"?><br /><?xfa generator="AdobeLiveCycleDesignerES_V8.2.1.3158.1.475346" APIVersion="2.8.8118.0"?><br /><xdp:xdp xmlns:xdp="http://ns.adobe.com/xdp/" timeStamp="2008-08-19T05:24:04Z" uuid="739066e1-62a8-4491-9bc8-293d69c06707"><br /><template xmlns="http://www.xfa.org/schema/xfa-template/2.6/"><br /> <?formServer defaultPDFRenderFormat acrobat8.1static?><br /> <subform name="SICFApp" layout="tb" restoreState="auto" locale="tr_TR"><br /> <pageSet><br /> <pageArea name="Page1" id="Page1"><br /> <contentArea x="0.25in" y="0.25in" w="8in" h="10.5in"/><br /> <medium stock="letter" short="8.5in" long="11in"/><br />.......