Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments

Error - Inserting "Query for Multiple Rows as XML" data into xfaForm

Avatar

Level 7
I create an XML output from an SQL query module in Workbench. I use the Set Value to assign the XML output to a xfaForm variable.



When the view the form, I get an error in Workspace and the form doesn't open. I think the format of the XML data may not be compatible with the XDP.



Is there a way to insert "Query for Multiple Rows as XML" data in xfaForm variable ?
6 Replies

Avatar

Level 10
You have to put the data under the data node of the xfaForm variable.



Jasmin

Avatar

Level 7
ok ! I still get the error.



I used the set value to assign the XML to xfaForm



/process_data/appform/object/data=/process_data/xml



When I view the form, I get "An error occurred creating the form" error in Workspace.

Avatar

Level 7
Jasmin - I tried to assign a sample xml I created from LiveCycle Designer and it worked just fine.



I guess the output from the SQL query is not compatible with the xfaForm variable.



How can I conver XML data ?

Avatar

Level 10
You just need to make sure the xml coming from the DB matches the xml the forms is expecting. If you use a schema then the data has to follow the schema.



If not, then the structure should follow the structure of your sample xml file.



Jasmin

Avatar

Level 7
The XML does match the form. I used the same output via RenderPDF to a documentForm variable(same form) and it worked just fine.



However in my situation, I need to use xfaForm.



I think there are xdp and xfa tags in the xml which make it compatible.



Do you have a working sample ?

Avatar

Level 7
Jasmin - I now understand what you are suggesting after reading a related topic http://www.adobeforums.com/webx?128@@.59b6f70e



I used a SetValue to assign the xml to the same level in the xfaForm.



/process_data/xfaForm/object/data/xdp/datasets/data/WorkflowSample/personaldetails=/process_data/xml/WorkflowSample/personaldetails.



Thank you for helping.