Highlighted

Error - Inserting "Query for Multiple Rows as XML" data into xfaForm

Avatar

Avatar

Aditya_S_

Avatar

Aditya_S_

Aditya_S_

12-12-2008

I create an XML output from an SQL query module in Workbench. I use the Set Value to assign the XML output to a xfaForm variable.



When the view the form, I get an error in Workspace and the form doesn't open. I think the format of the XML data may not be compatible with the XDP.



Is there a way to insert "Query for Multiple Rows as XML" data in xfaForm variable ?

Replies

Highlighted

Avatar

Avatar

Jasmin_Charbonn

Total Posts

(val/1000)?string[".0"]}K

Likes

149

Correct Answer

97

Avatar

Jasmin_Charbonn

Total Posts

(val/1000)?string[".0"]}K

Likes

149

Correct Answer

97
Jasmin_Charbonn

12-12-2008

You have to put the data under the data node of the xfaForm variable.



Jasmin
Highlighted

Avatar

Avatar

Aditya_S_

Avatar

Aditya_S_

Aditya_S_

12-12-2008

ok ! I still get the error.



I used the set value to assign the XML to xfaForm



/process_data/appform/object/data=/process_data/xml



When I view the form, I get "An error occurred creating the form" error in Workspace.
Highlighted

Avatar

Avatar

Aditya_S_

Avatar

Aditya_S_

Aditya_S_

15-12-2008

Jasmin - I tried to assign a sample xml I created from LiveCycle Designer and it worked just fine.



I guess the output from the SQL query is not compatible with the xfaForm variable.



How can I conver XML data ?
Highlighted

Avatar

Avatar

Jasmin_Charbonn

Total Posts

(val/1000)?string[".0"]}K

Likes

149

Correct Answer

97

Avatar

Jasmin_Charbonn

Total Posts

(val/1000)?string[".0"]}K

Likes

149

Correct Answer

97
Jasmin_Charbonn

15-12-2008

You just need to make sure the xml coming from the DB matches the xml the forms is expecting. If you use a schema then the data has to follow the schema.



If not, then the structure should follow the structure of your sample xml file.



Jasmin
Highlighted

Avatar

Avatar

Aditya_S_

Avatar

Aditya_S_

Aditya_S_

15-12-2008

The XML does match the form. I used the same output via RenderPDF to a documentForm variable(same form) and it worked just fine.



However in my situation, I need to use xfaForm.



I think there are xdp and xfa tags in the xml which make it compatible.



Do you have a working sample ?
Highlighted

Avatar

Avatar

Aditya_S_

Avatar

Aditya_S_

Aditya_S_

18-12-2008

Jasmin - I now understand what you are suggesting after reading a related topic http://www.adobeforums.com/webx?128@@.59b6f70e



I used a SetValue to assign the xml to the same level in the xfaForm.



/process_data/xfaForm/object/data/xdp/datasets/data/WorkflowSample/personaldetails=/process_data/xml/WorkflowSample/personaldetails.



Thank you for helping.