Highlighted

Email for Task Assigned is not sending to the mailbox

Avatar

Avatar

Han_Dao

Avatar

Han_Dao

Han_Dao

23-01-2009

Hi,



I am working on the process that need to send an email to the user to notify that there is a task that need to be process but I am not sure why it does not send email when the task is notified in the Workspace. I have enable the user task assigned in LC Admin but it seem to not working and the user could not receive any email when the task is await for process. Do I need to anything to make it work in the process or workbench? Any help would be appreciated.



Thanks much in advance,

Han Dao

Replies

Highlighted

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

26-01-2009

Do you check the settings for the user in WorkSpace (under Preferences)?



Also you need to reboot the app server once you've configured the email settigs in adminui.



Jasmin
Highlighted

Avatar

Avatar

Han_Dao

Avatar

Han_Dao

Han_Dao

27-01-2009

Hi Jasmin,



I checked the setting for the User in Workspace and the email was enabled. I re-configured the email setting in the adminui and reboot the app server but still could not get the email when the task is assigned. The message only show in the Workspace To Do list. Is there any thing that I need to set in the Workbench, Service? Please advise.



Thanks,

Han Dao
Highlighted

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

27-01-2009

Do you have email addresses configured for your users?



Did you configured the Home > Services > LiveCycle Process Management ES > Server Settings > Task Notifications -> Task Assignment?



What are the settings for you email server(Home > Services > LiveCycle Process Management ES > Server Settings > Email Settings)? Don't forget to check the "Enable Outgoing Message" checkbox.



Do you have any error in the server.log file?



Jasmin
Highlighted

Avatar

Avatar

Han_Dao

Avatar

Han_Dao

Han_Dao

27-01-2009

Hi Jasmin,



Answer for your questions:



1)the email was configured to take the email address from LDAP. Do I have I include it in the process?



2) Configured the Home > Services > LiveCycle Process Management ES > Server Settings > Task Notifications -> Task Assignment as bewlow:



-Subject: Task Assignment - Process: @@process-name@@. Task @@taskid@@ has been assigned to you.

- Notification Template: @@instructions@@

Click here to access the task:

http://@@notification-host@@:/workspace/Main.html?taskId=@@taskid@@



3) Email setting:

Home > Services > LiveCycle Process Management ES > Server Settings > Email Settings? Don't forget to check the "Enable Outgoing Message" checkbox.



The Email settings was set to use IRELAY4U with no user name and password is required, the email address is included, and the Enable box was also checked in the setting.



4) Error from the log file:

Caused by: com.adobe.idp.dsc.email.SendMailFailedException: Could not connect to SMTP host: IRELAY4U, port: 25;

nested exception is:

java.net.SocketException: Software caused connection abort: connect

at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithMapOfAttachments(EmailServiceImpl.java:738)

at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithDocument(EmailServiceImpl.java:353)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:618)

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:118)

... 114 more



Thanks,

Han Dao

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

27-01-2009

Oh. You're using an email service to send the email. That's something totally different than the built-in notification.



See post http://www.adobeforums.com/webx/.59b75753/1



Jasmin
Highlighted

Avatar

Avatar

Han_Dao

Avatar

Han_Dao

Han_Dao

27-01-2009

Hi Jasmin,



If I like to use the built-in notification, how do I make it work?



Thanks,

Han Dao
Highlighted

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

28-01-2009

You shouldn't have to add anything extra to your process.



When you use the User step, and have configured the email settings and the task settings in adminui and configure the preferences in Workspace, you should get an email automatically when new task is assigned to you.



Jasmin
Highlighted

Avatar

Avatar

Han_Dao

Avatar

Han_Dao

Han_Dao

28-01-2009

Hi Jasmin,



I did not use the email service in my process but I am not sure why it keep calling that email service and did not send email when the task is assigned as I have configured the email setting in the admin as show in the previous post. My process is a simple which is using Get Form, users as 3 different managers to approve for the process.
Highlighted

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

28-01-2009

Could not connect to SMTP host: IRELAY4U, port: 25 is the error that gets thrown.



Are you sure of that server name. Maybe you need to put the fully qualified name.



Jasmin