Highlighted

Dynamic tables with XML schema binding

Steffen_Kuhnt

09-07-2008

Hello,



I'm currently fighting a strange issue dealing with a complex dynamic form. This form contains multiple dynamic tables to which the user may add new lines or delete lines that are no longer needed. This is being implemented using the instanceManager and works just fine.



However, if I try to bind XML based data to this table, it looks like if rows added by the instance manager are always bound to the same record (they all contain identical values). The XML schema is correct, the issue also happens with sample XML data files.



This seems to have something to do with the programatically added lines, but I have run out of ideas ... Can anyone provide some pointers?



Thanks a million,



Steffen.

Replies

Highlighted

pguerett

10-07-2008

If you put a [*] at the end of the binding statement to indicate that there are more thna one of these nodes that should solve your issue.
Highlighted

Steffen_Kuhnt

14-07-2008

I probably need to look into this deeper -- but it sure looks like you are right, it seems to work!



Thank you very very much,



Steffen.
Highlighted

Avatar

Guest

06-02-2009

I have the same problem. I put a [*] at the end of the binding statement but I had another problem, the other rows are blank now when I use the form in a workflow.I´d like to bind the new instances of the rows to the xml schema. Do you guys have an idea how to do that? Do I have to use java script?



Thank you.
Highlighted

Avatar

Guest

30-03-2009

I have the same problem too. only the first row is submitted when I use the form in the workflow. Any idea how to solve that? thanks
Highlighted

Avatar

Guest

31-03-2009

Thanks for the reply, Paul.
I have the question about the schema,
say i have a table like this:
Item | Cost

A | 10.3

B | 21.1

Total| 31.4

and my schema is:







so when I bind the table row should it be $.ItemTable[*].Item ?
Highlighted

Steffen_Kuhnt

31-03-2009

Basically Paul is right.



What has often helped me is to drag and drop the node from the schema into an empty subform. Then you can have a look at how Designer would do it - this can clear things up sometimes.



S.