Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

RTE Issue with AEM Cloud

sathyaprakasha2
Level 2
Level 2

Team , I am facing weird issue while adding a rte component in dialog field.

Issue : If I click on the highlighted feature(i.e. which has dropdown box) it doesn't allow us to scroll down and getting the below error message on console.

 

`preventOverflow` modifier is required by `hide` modifier in order to work, be sure to include it before `hide`! coralui3.min.js

 

sathyaprakasha2_0-1601027953338.png

 

Experience Manager
1 Accepted Solution
ChitraMadan
Correct answer by
Community Advisor
Community Advisor

Hi @sathyaprakasha2 ,

 

This has been fixed in 6.4.8

Please refer to NPR-27579

AEM 6.4 Service Pack Release Notes

 

Workaround, just in case you can't install SP at the moment:

Create a clientlib

Screenshot 2020-09-25 at 16.18.24.png

 

Create a css file with this code

.cq-Dialog:not([fullscreen]) .cq-RichText-editable {
height: 20rem !important;
}

View solution in original post

8 Replies
ChitraMadan
Correct answer by
Community Advisor
Community Advisor

Hi @sathyaprakasha2 ,

 

This has been fixed in 6.4.8

Please refer to NPR-27579

AEM 6.4 Service Pack Release Notes

 

Workaround, just in case you can't install SP at the moment:

Create a clientlib

Screenshot 2020-09-25 at 16.18.24.png

 

Create a css file with this code

.cq-Dialog:not([fullscreen]) .cq-RichText-editable {
height: 20rem !important;
}

View solution in original post

sathyaprakasha2
Level 2
Level 2
Hi, Still I am facing the issue.. the above css is loading....
ChitraMadan
Community Advisor
Community Advisor
Try to increase the height in css as per your requirement.
sathya_prakasha
Level 5
Level 5
No..my issue is different.. its not working in both inline and full screen...once I click on the above highlighted buttons and try to scroll down to fill other fields ....it doesn't allow us to scroll down,,
ChitraMadan
Community Advisor
Community Advisor

Hi @sathya_prakasha, yeah..may be it could be a different problem.

 

Are you not able to see the drop down at all?

sathya_prakasha
Level 5
Level 5
I am able to see the dropdown , its not related to dropdown or height issue...if I click on highlighted(dropdown - image above) related fields ..scroll is not working..
Arun_Patidar
Community Advisor
Community Advisor

what version of SDK are you using? I am using  2020.6.3800.20200626T210738Z-200604

and did not see the issue.

sathya_prakasha
Level 5
Level 5
Hi Arun , Thanks for your reply ..I am using 2020.7.3981.20200731T205128Z.... I thought the issue du to popper.js but when we inject the same component on fresh instance.. it not working... its working fine on aem 6.5 and 6.4