Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

"com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved"

keerthid7215849
Level 3
Level 3

"com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved" issue when trying to do mvn install in 6.3. can anyone help me to resolve. Thanks

1 Accepted Solution
smacdonald2008
Correct answer by
Level 10
Level 10

How are you building your project. You should be using Uber 6.3 JAR. That will resolve your issue.

See how we built the custom component in this artilce -- Creating an Experience Manager YouTube Component

This covers use of AEM 6.3 UBER:

<version>6.3.0</version>

View solution in original post

10 Replies
smacdonald2008
Correct answer by
Level 10
Level 10

How are you building your project. You should be using Uber 6.3 JAR. That will resolve your issue.

See how we built the custom component in this artilce -- Creating an Experience Manager YouTube Component

This covers use of AEM 6.3 UBER:

<version>6.3.0</version>

View solution in original post

Prince_Shivhare
Community Advisor
Community Advisor

Hi,

I am agree with Scott.

please change the uber jar AEM version to 6.3.

Also check with command mvn clean install -PautoInstallPackage

~Prince

keerthid7215849
Level 3
Level 3

it's working now. Thank you smacdonald2008

Also, there are still unresolved issues for

"javax.persistence -- Cannot be resolved

org.apache.commons.beanutils,version=[1.9,2) -- Cannot be resolved

org.hibernate -- Cannot be resolved

org.hibernate.cfg -- Cannot be resolved

org.hibernate.classic -- Cannot be resolved

org.hibernate.dialect -- Cannot be resolved

org.hibernate.dialect.function -- Cannot be resolved

org.hibernate.transform -- Cannot be resolved

"

Can you please suggest any solution for these...

ppanayotov
Level 1
Level 1

This is a helpful post, I would also suggest that along with

1. adding the uber jar version changes in the root pom:

<dependency>

               <groupId>com.adobe.aem</groupId>

               <artifactId>uber-jar</artifactId>

                <version>6.3.0</version>

                <classifier>obfuscated-apis</classifier>

               <scope>provided</scope>

</dependency>

2. ensuring that you replace the dependencies for the core pom:

<dependency>

            <groupId>com.adobe.aem</groupId>

            <artifactId>aem-api</artifactId>

  </dependency>

with:

  <dependency>

        <groupId>com.adobe.aem</groupId>

       <artifactId>uber-jar</artifactId>

      <classifier>obfuscated-apis</classifier>

</dependency>

3. Execute: mvn clean install -PautoInstallPackage

Thank you!

janarthanand
Level 1
Level 1

Above update is not working for me. I have updated the uber-jar version to 6.3 and 6.4 both not worked. Please help me on this error.

Please help me on this issue. smacdonald2008

sayalichougale
Level 2
Level 2

Hi,

I am facing a similar issue for AEM 6.4 migration from AEM 6.1.I have added the uber-jar dependency yet its not working for me.

Maven Uber Jar dependency:

               <dependency>

              <groupId>com.adobe.aem</groupId>

               <artifactId>uber-jar</artifactId>

               <version>6.4.0</version>

               <classifier>apis</classifier>

               <scope>provided</scope>

               </dependency>

Also it gives me a build error if I try to add obfuscated-apis

    <dependency>

    <groupId>com.adobe.aem</groupId>

    <artifactId>uber-jar</artifactId>

    <version>6.4.0</version>

    <classifier>obfuscated-apis</classifier>

    </dependency>

Can I know what is the solution for this issue.

com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved

Jörg_Hoh
Employee
Employee

In AEM 6.4 SP4 (which I have handy right here) the java package "com.adobe.cq.sightly" is exported by the bundle "com.adobe.cq.sightly.cq-wcm-sightly-extension" and the package version is 3.2.0.

This means, that your code is stil compiled against an older package version of this bundle. Most it is still compiling against AEM 6.1 and your update to the uber-jar is not reflected in your build.

sayalichougale
Level 2
Level 2

Hi Jorg Hoh,

The AEM 6.4 instance which I am using for migration is one on which I have performed in place migration i.e replaced the AEM 6.1 jar with the new AEM 6.4 jar.

I checked for the com.adobe.cq.sightly.cq-wcm-sightly-extension package in system console of my instance and found its version to be 1.5.12. Please find the below screen shot. Also I have added the cq-wcm-sightly-extension dependency in my project pom.xml ,along with the uber-jar dependency.

       <dependency>

       <artifactId>cq-wcm-sightly-extension</artifactId>

       <version>1.5.12</version>

       <groupId>com.adobe.cq.sightly</groupId>

       <scope>provided</scope>

        </dependency>

I am still facing the same issue.

com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved

1830448_pastedImage_1.png

sayalichougale
Level 2
Level 2

Also the dependency for com.adobe.cq.sightly.cq-wcm-sightly-extension mentioned under /system/console/depfinder also

has the dependency of :

<dependency>

<artifactId>cq-wcm-sightly-extension</artifactId>

<version>1.5.12</version>

<groupId>com.adobe.cq.sightly</groupId>

<scope>provided</scope>

</dependency>

Do I need to add any other dependency apart from this in my pom.xml ?

Jörg_Hoh
Employee
Employee

Your AEM instance shows the right dependencies for AEM 6.4, but your build environment uses different dependencies; obviously the dependencies of the artifact you provided are overwritten by other artifacts (probably the uber.jar)