since ‎08-02-2019
‎10-12-2019
sayalichougale
Level 1
Re: org.joda.time,version=[1.6,2) and org.joda.time.format,version=[1.6,2) dependency cannot be resolved in AEM 6.4 sayalichougale - Adobe Experience Manager
Hi Scott,I checked the dependency finder,please find the below screen shots of the same:In dependency finder as well as the bundle console shows the version of the package as 2.9.1 which I have already added as maven dependency in the project.
2136
Views
0
Likes
0
Replies
Re: org.joda.time,version=[1.6,2) and org.joda.time.format,version=[1.6,2) dependency cannot be resolved in AEM 6.4 sayalichougale - Adobe Experience Manager
Hi,I have already added uber jar dependency in the pom.xml file.Please find the below dependency which is added in the pom.xml file of the project: com.adobe.aem uber-jar 6.4.0 apis provided What does uber jar with deprecated API's means?All the other bundles in the same instance are working properly with addition of above uber-jar dependency.
2136
Views
0
Likes
2
Replies
org.joda.time,version=[1.6,2) and org.joda.time.format,version=[1.6,2) dependency cannot be resolved in AEM 6.4 sayalichougale - Adobe Experience Manager
Hi,As I am trying to migrate my backend code base from AEM 6.1 to AEM 6.4, I came across the following issue.The dependency for org.joda.time,version=[1.6,2) and org.joda.time.format,version=[1.6,2) cannot be resolved.According to one of the helpx.adobe.com some of the methods for this dependency are depricated in 6.4. Can anyone suggestion the alternative for this dependency. I have added the below maven dependency in my project pom.xml:joda-time2.9.1joda-timeprovidedPlease find the following o...
2295
Views
0
Likes
4
Replies
Re: "com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved" sayalichougale - Adobe Experience Manager
Also the dependency for com.adobe.cq.sightly.cq-wcm-sightly-extension mentioned under /system/console/depfinder also has the dependency of : cq-wcm-sightly-extension 1.5.12 com.adobe.cq.sightly provided Do I need to add any other dependency apart from this in my pom.xml ?
1137
Views
0
Likes
0
Answers
Re: "com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved" sayalichougale - Adobe Experience Manager
Hi Jorg Hoh,The AEM 6.4 instance which I am using for migration is one on which I have performed in place migration i.e replaced the AEM 6.1 jar with the new AEM 6.4 jar.I checked for the com.adobe.cq.sightly.cq-wcm-sightly-extension package in system console of my instance and found its version to be 1.5.12. Please find the below screen shot. Also I have added the cq-wcm-sightly-extension dependency in my project pom.xml ,along with the uber-jar dependency. cq-wcm-sightly-extension 1.5.12 com....
1148
Views
0
Likes
0
Answers
Re: "com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved" sayalichougale - Adobe Experience Manager
Hi,I am facing a similar issue for AEM 6.4 migration from AEM 6.1.I have added the uber-jar dependency yet its not working for me.Maven Uber Jar dependency: com.adobe.aem uber-jar 6.4.0 apis provided Also it gives me a build error if I try to add obfuscated-apis com.adobe.aem uber-jar 6.4.0 obfuscated-apis Can I know what is the solution for this issue.com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved
1136
Views
0
Likes
0
Answers
Re: Up gradation of code base from AEM 6.1 to 6.4 (Upgrade WCMUse to WCMUsePojo) sayalichougale - Adobe Experience Manager
Hi gauravb10066713,Is maven-scr-plugin:1.7.4 generated by archetype 11 or is it carried over from your 6.1 pom.xml?Ans:::::::::: The maven-scr-plugin:1.7.4 is carried over from 6.1 pom.xml.As I am working on migration from AEM 6.1 to 6.4, I am slow and steadily changing the existing code targeting the backward incompatible code first.As suggested I have kept the Uber jar at the bottom of the dependency list.
916
Views
0
Likes
0
Answers
Up gradation of code base from AEM 6.1 to 6.4 (Upgrade WCMUse to WCMUsePojo) sayalichougale - Adobe Experience Manager
Hi,As I am trying to upgrade from AEM 6.1 to AEM 6.4, I need to change the extension of all the classes from WCMUse to WCMUsePojo. Have added the required dependency in the projects parent pom.xml as well : com.adobe.aem uber-jar 6.4.0 obfuscated-apis provided But I am getting the following error during the maven build of the project:[ERROR] Failed to execute goal org.apache.felix:maven-scr-plugin:1.7.4:scr (generate-scr-descriptor) on project abcd: Execution generate-scr-descriptor of goal org...
3694
Views
1
Like
5
Answers and Comments
Re: Translation Enhancements in AEM 6.4 (AEM Machine Translation for Language Copy) sayalichougale - Adobe Experience Manager
Hi,Is it possible to extended the in build Microsoft Translator to translate pages in English language to Indian Regional Language like Tamil, Kannada, Marathi, Bengali apart from Hindi which is supported by default in AEM 6.4. If anyone has used Google Translator plugin to achieve the same in their website can also reply if there any Google Translator Plugin which can be used to achieve the same.
825
Views
0
Likes
0
Answers
Translation Enhancements in AEM 6.4 (AEM Machine Translation for Language Copy) sayalichougale - Adobe Experience Manager
Hi,I was trying to implement the new feature in AEM 6.4 multi language translation. But the end result for me is not as expected. According to my understanding this feature will translate the content on the selected page hierarchy to the selected language by using Microsoft Translator but on implementation the content was not translated to the selected French Language.Please find the below reference link which I had followed.Adobe Experience Manager Help | Translation Enhancements in AEM Please ...
936
Views
1
Like
3
Answers and Comments
Likes given to
Likes from