Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

keerthid7215849
Community profile keerthid7215849 Level 2
Job title here
Location here
4 BADGES
Level 2

Level 2

Learn more
Joined the community 13-04-2016 11:17:37 AM
Offline
Top badges earned by keerthid7215849
Customize the badges you want to showcase on your profile
Re: what is the best approach? Servlet or Node
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
We are trying to display in component dialog select field

Views

2.0K

Likes

0

Replies

1
what is the best approach? Servlet or Node
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
As of now, we have a list of people as a node for each person in jcr. We are trying to get all the people names in a drop-down using a servlet.But, we can also create a node with a property holding the all the names as a json and call the property value in node instead of calling a servlet every time when we use it. Also, I need to update the JSON value in this node whenever a new name added or existing name deleted. I'm not sure about which approach I need to implement. servlet or creating a no...

Views

2.2K

Likes

0

Replies

6
Calendar Community Component
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Hi,I'm new to Community Components and I'm trying to understand calendar component in AEM 6.3. I'm so confused about the privileged user here. How can I create privileged users? Is it same as normal AEM users? Can I customize the calendar component by extending. I tried to extend but it's not working as expected. is there any documentation how to implement calendar component in aem 6.3Thanks in advance

Views

759

Likes

0

Replies

2
Re: Unable to access dam using oauthservice system user
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I'm using this in SlingAllMethodsServlet coz every user should be able to generate pdf and the servlet is inside bundle. I configured the Bundle Symbolic name in the Sling Mapping Service configuration. I also checked that I gave permission to the oauthservice user for the location. But still not sure why pdf generator is not able to access the images.below are the configsconfig.setLicenseKey(license);config.setBaseURL(URL);config.setAuthenticationCredentials(new KeyValuePair("oauthservice", "")...

Views

1.0K

Likes

2

Replies

0
Re: Unable to access dam using oauthservice system user
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
But, as I mentioned in my original question, I'm using the system user and Sling Mapping Service but pdf generator is not being able to access the images in dam

Views

1.0K

Likes

0

Replies

2
Re: Unable to access dam using oauthservice system user
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
This worked but, here again, I have to mention username and password of the user in the service which I don't want to do. Is there any other way that I can do to achieve this?

Views

2.4K

Likes

0

Replies

6
Re: Unable to access dam using oauthservice system user
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Yeah, That's true. Here I used oauthservice system user and gave permissions for the DAM images folder. But this is not working in 6.3

Views

2.4K

Likes

0

Replies

8
Re: Unable to access dam using oauthservice system user
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I couldn't find anything that this is not supported. I might miss some thing. Can you please mention any documentation to implement this functionality in a recommended way.Thanks in advance

Views

2.4K

Likes

0

Replies

10
Unable to access dam using oauthservice system user
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I'm trying to access images in the dam from the third party pdf generator. I'm using oauthservice system user by the writeService OSGI configuration setting. I also gave permissions to oauthservice user. Now I'm unable to generate an image in the pdf. It worked in AEM 6.1, but not in AEM 6.3. Also, it's working if I provide "admin" username and password.But, I don't wanna use admin details. Can you please help if I'm missing anything here...

Views

2.7K

Likes

2

Replies

12
Re: javax.persistence -- Cannot be resolved
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I accept for HIBERNATE dependencies but is it same for "javax.persistence" too

Views

725

Likes

0

Replies

0
javax.persistence -- Cannot be resolved
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
There are unresolved issues "javax.persistence -- Cannot be resolvedorg.apache.commons.beanutils,version=[1.9,2) -- Cannot be resolvedorg.hibernate -- Cannot be resolvedorg.hibernate.cfg -- Cannot be resolvedorg.hibernate.classic -- Cannot be resolvedorg.hibernate.dialect -- Cannot be resolvedorg.hibernate.dialect.function -- Cannot be resolvedorg.hibernate.transform -- Cannot be resolved"when trying to do mvn install in 6.3. can anyone help to resolve these issues? Thanks, in-advance.

Views

1.2K

Likes

0

Replies

4
Re: "com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved"
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
it's working now. Thank you smacdonald2008Also, there are still unresolved issues for"javax.persistence -- Cannot be resolvedorg.apache.commons.beanutils,version=[1.9,2) -- Cannot be resolvedorg.hibernate -- Cannot be resolvedorg.hibernate.cfg -- Cannot be resolvedorg.hibernate.classic -- Cannot be resolvedorg.hibernate.dialect -- Cannot be resolvedorg.hibernate.dialect.function -- Cannot be resolvedorg.hibernate.transform -- Cannot be resolved"Can you please suggest any solution for these...

Views

1.5K

Likes

0

Replies

0
"com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved"
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
"com.adobe.cq.sightly,version=[2.2,3) -- Cannot be resolved" issue when trying to do mvn install in 6.3. can anyone help me to resolve. Thanks

Views

6.6K

Likes

2

Replies

10
Re: Trying to set the image path Dynamically
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager Assets
Hi Veena,I'm trying this in classic UI and fetching as JSON through ajax.I wrote a listener for the drop down with"selectionchanged" event. Once the dropdown value changes, the value append to the request and the response is JSON with all the element. In that imagepath is one of them. I'm setting all the values to particular fields. Now got struck with the smartimage field. I wanna set the path in smartimage as the other fields. This is my requirement.Thanks

Views

2.3K

Likes

0

Replies

0
Re: Trying to set the image path Dynamically
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager Assets
This is kind of urgent requirement for me to do. Any help!!

Views

2.3K

Likes

0

Replies

1
Trying to set the image path Dynamically
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager Assets
Hi,I'm trying to set the image in the smart image panel according to the dropdown value.I tried to the change the value like below"dialog.getField("./file").fileReferenceField.setValue(result.image);"dialog.getField("./file").referencedFileInfo.dataPath = result.image;dialog.getField("./file").originalRefImage.dataPath = result.image;Nothing worked. Can anyone help me to achieve this.Thank you in advance

Views

2.6K

Likes

0

Replies

4
Re: Argument cannot be null if path is not absolute: apps.sling.servlet.errorhandler.ResponseStatus
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Here is the code : @Service(ListOfMovies.class)@SlingServlet(paths = {"/bin/moviename"}, generateComponent = false)@Component(label = "Dropdown Movie data provider", description = "This servlet provides list of movie names in drop down",enabled = true, immediate = true, metatype = false)public class ListOfMovies extends SlingSafeMethodsServlet { private static final Logger LOGGER = LoggerFactory.getLogger(ListOfIPs.class); @Override protected void doGet(SlingHttpServletRequest request, SlingHttp...

Views

702

Likes

0

Replies

0
Argument cannot be null if path is not absolute: apps.sling.servlet.errorhandler.ResponseStatus
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Servlet is not wotking and throwing 404 error. I checked the logs its showing Caused by: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: Argument cannot be null if path is not absolute: apps.sling.servlet.errorhandler.ResponseStatus at org.apache.sling.scripting.core.impl.DefaultSlingScript.service(DefaultSlingScript.java:481) at org.apache.sling.servlets.resolver.internal.SlingServletResolver.handleError(SlingServletResolver.java:762) ... 77 common frames omittedCaused by: j...

Views

1.6K

Like

1

Replies

3
Re: using getAdministrativeResourceResolver(null) in AEM 6
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I used the symbolic bundle as showing in the video. I used general user instead of system user because its AEM 6.0. The issue is with the ResourceResolverFactory for me. its showing null. So I tried to get it through the Bundle Context and its resolved. Thank you.

Views

1.2K

Likes

0

Replies

0
Re: using getAdministrativeResourceResolver(null) in AEM 6
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I also change the dependency version of "org.apache.sling.api". Still no clue.

Views

1.2K

Likes

0

Replies

0
Re: using getAdministrativeResourceResolver(null) in AEM 6
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I tried complete video step by step But still facing the issue. Its showing ResourceResolverFactory is Null.

Views

1.2K

Likes

0

Replies

0
Re: using getAdministrativeResourceResolver(null) in AEM 6
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
I'm facing the similar issue . Getting "java.lang.NullPointerException: null" for getServiceResourceResolver(param); Any Help?

Views

1.2K

Likes

0

Replies

0
Standard tags are not working in the Dispatcher.
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Hi,The issue is, I created a tag under standard tags and assigned to the page. I publish the page. The tags I can see in the metadata of the page in author instance and the publish instance.But, I cant see the tags in the Dispatcher.

Views

475

Likes

0

Replies

0
Re: Issue with the DAM Update Asset
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
This worked for me . Thank you so much.

Views

999

Likes

0

Replies

0
Re: Issue with the DAM Update Asset
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
The process for the Dynamic Media Video Service Process is com.day.cq.dam.s7dam.common.process.VideoProxyServiceProcess and Yes, it's installed in the instance which is on cloud. But still its showing No process selected in the Dam Update Asset workflow. Do I need to do any other configuration or anything in Amazon cloud to fix this issue. Thanks for the reply.

Views

870

Likes

0

Replies

0
Re: Issue with the DAM Update Asset
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
keerthid72158491 wrote... HI, I'm new to AEM. This is the first time I'm using Dam Update Asset workflow. I edited workflow in a way that when I upload any images, the workflow needs to create renditions. The workflow is working perfectly in local server. when I try to deploy the same model in the server which is in the cloud, the process step "Dynamic Media Video Service Process" in workflow is automatically turning to "No process selected" instead of "com.day.cq.dam.s7dam.common.process". Also...

Views

871

Likes

0

Replies

0
Issue with the DAM Update Asset
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
HI,I'm new to AEM. This is the first time I'm using Dam Update Asset workflow. I edited workflow in a way that when I upload any images, the workflow needs to create renditions. The workflow is working perfectly in local server. when I try to deploy the same model in the server which is in the cloud, the process step "Dynamic Media Video Service Process" in workflow is automatically turning to "No process selected" instead of "com.day.cq.dam.s7dam.common.process". Also attaching the screenshot o...

Views

3.2K

Likes

2

Replies

6
Configuring dispatcher with IIS in windows 10
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Hi,I'm facing this error "HTTP Error 404.0 - Not Found The resource you are looking for has been removed, had its name changed, or is temporarily unavailable." when I setup dispatcher to the IIS. I tried all the steps mentioned in documentation file. I also tried the step given by Sham HC in this thread "http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manager.topic.html/forum__arow-i_have_spentthepas.html" but no use.This is the detailed error Inform...

Views

8.0K

Likes

0

Replies

5
Change the host.prefix for the internal inbox notification.
Avatar
Validate 1
Level 2
keerthid7215849
Level 2

Likes

9 likes

Total Posts

29 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
keerthid7215849
- Adobe Experience Manager
Hi,I'm unable change the host.prefix for the workflow inbox notification.I want to the change the URL of the page under the Content column in the notifications of "http://localhost:4502/inbox". I tried to add the custom configurations in the config folder "com.day.cq.workflow.impl.email.EMailNotificationService" and "com.day.cq.workflow.impl.email.TaskEMailNotificationService" and mention host.prefix property, but still no use. Can anyone help me to change the host. prefix.Thanks.

Views

711

Likes

0

Replies

1
Likes given to
Likes from