Expand my Community achievements bar.

SOLVED

Deactivated pages AEM author still show on live site

Avatar

Level 2

 

Hi , 

 

We deactivated page in aem author but still that page is available in live site.

Kindly help me how to reslove this issue.

 

Thanks,

Parha.

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hello @ParthasaradhiGa 

 

You probably have problem on multiple levels:

 

1. Page is cached on CDN/dispatcher: 

- CDN/dispatcher do not have capability to render a page. So, if its blank on publish, it should be same on CDN/dispatcher. But, in current case, you are getting a proper content on live site. 

This clearly means content is cached on CDN/dispatcher. They need to be cleared,

 

2. Blank page on publish:

If you have the replication/error logs, please check the messages related to this page in both author and publish. 

That might give you an idea about what happened. Once its resolved, you can try publishing and unpublishing the page again. That should ideally delete it from publish.

 

Please clear the cache for the page on CDN/dispatcher after resolving publish instance.


Aanchal Sikka

View solution in original post

6 Replies

Avatar

Community Advisor

Hi, 

 

Please check the following:

- Check if the page is not cached in the CDN.

- Check if the page is not cached in your browser

- Check if there are any issues in the activation queue, (the queue is blocked)

- Check the logs to make sure the deactivation process went ok



Esteban Bustamante

Avatar

Level 7

Have you checked, whether the page is present in prod publish sites? Also, if you have IP based access to prod publishers, better to check there.

Avatar

Level 2

Yes, The page is available in prod publish crx/de, When trying to load it's opening blank page without content.But live site showing page content. kindly let me know what I have to do to reslove this issue.

Avatar

Correct answer by
Community Advisor

Hello @ParthasaradhiGa 

 

You probably have problem on multiple levels:

 

1. Page is cached on CDN/dispatcher: 

- CDN/dispatcher do not have capability to render a page. So, if its blank on publish, it should be same on CDN/dispatcher. But, in current case, you are getting a proper content on live site. 

This clearly means content is cached on CDN/dispatcher. They need to be cleared,

 

2. Blank page on publish:

If you have the replication/error logs, please check the messages related to this page in both author and publish. 

That might give you an idea about what happened. Once its resolved, you can try publishing and unpublishing the page again. That should ideally delete it from publish.

 

Please clear the cache for the page on CDN/dispatcher after resolving publish instance.


Aanchal Sikka

Avatar

Community Advisor

Hello @ParthasaradhiGa ,

To resolve situations like these, what I have tried in the past is to create a page with the same name in the same path in AEM author and send a deactivation request to production publishers. This action should also clear the dispatcher cache for you.

If you do not wish to create a page, you could also look at forming a command line request similar to what the AEM replication agents use.

Something like as follows,

 

curl -u username:password 'https://aem-author/<page-path>'

 

Check the user used in the command above has permissions to delete file on the AEM publisher servers.

Avatar

Level 7

Hi @ParthasaradhiGa 

Above solution might work for you.  Or else, if you want to get rid of few pages in prod publish, which is not present in prod author, do these steps.

 

Suppose if you want to delete these pages under home page

/content/abc/en/home/page1
/content/abc/en/home/page2

Then is prod author package manager, create package with filter: /content/abc/en/home  Build the package. then click on Replicate.  this will replicate to all prod publish instances.