Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

PreetpalSinghBi
Community profile PreetpalSinghBi Level 2
Job title here
Location here
8 BADGES
Level 2

Level 2

Learn more
Joined the community 29-05-2017 8:33:17 AM
Offline
Top badges earned by PreetpalSinghBi
Customize the badges you want to showcase on your profile
Re: How to connect a Dispatcher to a Load Balancer where...
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
@berliant @ @Albin_Issac You are absolutely correct! This does not look ideal, however there are multiple factors that lead us to this setup. There are few more options on the table that we are considering, however, I wanted to explore this option before we simply drop it. I have been able to connect 2 dispatchers in a row and the traffic flows as expected #2 > #1 > Publishers and back. So, that is solved and I have tested it. It works over HTTP.Dispatcher #2 > LB (HTTP) > Dispatcher #1 > Publis...

Views

311

Like

1

Replies

1
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
@kautuk_sahni thanks for facilitating.

Views

164

Likes

0

Replies

0
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
ok @Jörg_Hoh thanks for the update. I will mark this complete.

Views

184

Likes

0

Replies

0
How to connect a Dispatcher to a Load Balancer where the LB is in turn connected to other dispatchers
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
Hello Guys, Need your suggestions on a Apache/Dispatcher setup. (Please see the attached diagram) ScenarioThe customer has the standard AEM Publish and Apache web servers (shown as #1 in the diagram) already setup and there are multiple websites hosted here.For one new site, there is a need to access the site through a new set of web servers (shown as #2 in the diagram) hosted on a 3rd party cloud.If you look closely, this is a different-than-regular scenario with 2 web servers in the request pa...

Views

400

Likes

0

Replies

4
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
@Jörg_Hoh This did not work for me. I checked it twice.I am using Apache 2.4.29 on Ubuntu 18.x for server #2 and Apache 2.4.28 on RHEL 7.5 for server #1.DispatcherUseServerNameInVia 0I could still see the similar exceptions as before complaining about declining the call as the request is already served by Dispatcher. I could find any Adobe documentation on this. @Shashi_Mulugu This worked just perfect!RequestHeader unset viaRequestHeader unset server-agentI would like to see if there is a standa...

Views

184

Likes

2

Replies

1
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
I will try this.

Views

209

Like

1

Replies

2
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
Let me give this a try @Jorg and @Shashi_Mulugu .

Views

178

Like

1

Replies

0
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
shashi1223Outermost Apache (#2) has the Rewrite rules with the [PT] flag to pass on the request to outermost dispatcher (#2) and then further pass the request to innermost Apache (#1) and from there to (dispatcher #1) -> Publish.The rewrite rules look like this,RewriteRule ^/$ /content/aem-repository-path/home.html [PT]RewriteRule ^/index(.html)?$ /content/aem-repository-path/home.html [PT].... Innermost Apache (#1) vhost file just registers the port number for the site and the dispatcher module...

Views

200

Like

1

Replies

0
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
@Shashi_Mulugu No, the dispatcher #2 are apache+dispatcher. No CDN in this equation.

Views

281

Likes

0

Replies

0
Re: Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
@Shashi_Mulugu Yes, i tried that and problem I faced is dispatcher (#1) declines the request as request is already processed by the dispatcher #2. This is by Dispatcher design.

Views

284

Likes

0

Replies

0
Setup two Dispatchers in series arrangement
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
Hello Guys, Need your suggestions on a Apache/Dispatcher setup. (Please see the attached diagram) ScenarioThe customer has the standard AEM Publish and Apache web servers (shown as #1 in the diagram) already setup and there are multiple websites hosted here.For one new site, there is a need to access the site through a new set of web servers (shown as #2 in the diagram) hosted on a 3rd party cloud.If you look closely, this is a different-than-regular scenario with 2 web servers in the request pa...

Views

562

Likes

0

Replies

18
Re: How to add additional columns in workflow instances w...
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
Hello @berliant @Vish_dhaliwal, Thanks.To add additional columns to the "workflow instances" in TouchUI, with AEM 6.5, which one is recommended to overlay from,a. /libs/wcm ORb. /libs/cq/workflow/admin/console/content/instances/jcr:content/views/list/columns? As far as I can see the relevant nodes exist only under /libs/cq/workflow/admin/console/content/instances/jcr:content/views/list/columns, but, that section is greyed out (I suppose that means - Either Deprecated OR Internal to Adobe and so ...

Views

1.3K

Like

1

Replies

0
Re: ACS Commons Sitemap Generator error: No renderer for...
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
The issue is resolved after creating the OSGi configs from the web console.

Views

1.3K

Likes

0

Replies

0
Re: How to create XML Sitemap and Robots in AEM?
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
Hello @Arun_Patidar can you suggest where the contentType("text/xml") be set?I have 2 page page resource types, each has the "sling:resourceSuperType" set to "core/wcm/components/page/v2/page".I am using the ACS Commons Sitemap Generator as per the instructions here,https://adobe-consulting-services.github.io/acs-aem-commons/features/sitemap/index.html and http://www.flexibledesigns.rs/sitemap-creation/ One of the .sitemap.xml requests return text/html and another returns text/xml. I did not do ...

Views

9.2K

Likes

0

Replies

0
ACS Commons Sitemap Generator error: No renderer for extension xml
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
AEM 6.3.3.5/RHEL/Core components 2.7.0/ACS-Commons 3.17 I have 2 page page resource types, each has the "sling:resourceSuperType" set to "core/wcm/components/page/v2/page".To generate sitemap on the topmost page of the site, I am using the ACS Commons Sitemap Generator. So, as per the instructions herehttps://adobe-consulting-services.github.io/acs-aem-commons/features/sitemap/index.html and http://www.flexibledesigns.rs/sitemap-creation/I created two OSGi configs by the name: com.adobe.acs.comm...

Views

1.4K

Likes

0

Replies

2
Multilingual header and footer using Experience Fragments (Core) component
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
AEM 6.3.3.5/Linux I have been trying to use the setup for header and footer as described on this page: https://docs.adobe.com/content/help/en/experience-manager-core-components/using/get-started/localization.html The business need is to use Experience Fragments to build header and footer for multiple languages at a central location and include them into the pages when a user is on a page for a language.Has anyone attempted to use this?I tried creating the same structure as described, but never g...

Views

593

Likes

0

Replies

0
Re: How to do new datatype in Content Fragment Models?
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
Is it possible to add a custom RTE plugin option to the Content Fragment RTE field?

Views

3.3K

Likes

0

Replies

2
Re: TouchUI field description(tooltip) property in a form/select box not adding carriage return on rendered page
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Experience Manager
How did you reproduce Scenario #2 with broken css?

Views

3.7K

Likes

0

Replies

1
Re: DTM Rule Approved, but does not show up on the site included.
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
I tried it, it shows the latest, June 1st, when i did publish my code, and this is correct. However, I still do not see my rules firing when i set _satellite.setDebug(true); in the browser console.The same DTM web property has staging (pre-production environment) report suite configured. When i run the same rules on "staging" mode environment, i see my rule getting triggered in the browser console and the data gets tracked in the eVar reports.However, when in "production" mode, I do not see the ...

Views

1.3K

Likes

0

Replies

1
Re: DTM Rule Approved, but does not show up on the site included.
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Anyone?

Views

829

Likes

0

Replies

0
Re: DTM Rule Approved, but does not show up on the site included.
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Also to mention, the already present "older" rules are working fine.The new rules do not.

Views

830

Likes

0

Replies

0
DTM Rule Approved, but does not show up on the site included.
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Hi All,I have few set of rules that we configured to the web property. this web property has 2 report suites configured.For the one corresponding to Staging, the rules fire correctly, however, when i "Approved" and "Published" the rules to use them on the production, none of the rules trigger.The website includes both the header and footer code for DTM property.When i look at the satellite js included on the page it does Not contain the rules i created neither for -staging JS not the productions...

Views

3.2K

Likes

0

Replies

7
"_satellite is not defined". Analytics script injected using DTM does not work on Mozilla Firefox & IE, works in Chrome.
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Dynamic Tag Management
Hi all,I see an issue where Analytics script injected using DTM does not work on Mozilla Firefox & IE, works in Chrome.I have already done the following initial checks on FF primarily,1. The DTM satellite script opens up correctly in Firefox when opened via "view page source" and clicking on the link for the satellite js.2. It has the necessary data in it and is not blank. initially it showed not able to access, but by allowing the exception, i am able to access it now.3. Another script _satelli...

Views

7.0K

Likes

3

Replies

5
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Forgot to mention, there was an exit rule triggering after i navigate away from the search page, and so, all the eVars and events on the page were sent again with the exit link.

Views

1.3K

Likes

0

Replies

0
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Thanks.I tried setting "Expire after" to Hit & allocation as suggested above, but the same problem continued to persist.I resolved this issue by resetting the variables in this manner. Do you see any side effects by doing this? s.events='';s.linkTrackVars='';s.linkTrackEvents = '';

Views

1.0K

Likes

0

Replies

0
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Hi,Can you tell me how can i get in touch directly with support team? Is there a online chat option available?

Views

1.0K

Likes

0

Replies

0
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
I tried with the following suggestion, however, the link tracking stops with this "false" parameter. Unfortunately, it did not help in my case.s.tl(false,'o', "Search Filter Click event"); As I can see the Adobe Analytics image request & its variables being sent correctly, could it be that the report configuration may be wrong? I mean is there a configuration(s) with the Report Suite or the eVar report that could be incorrect &/or I should verify/double check it/them?

Views

1.0K

Likes

0

Replies

0
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
The format of the eVar value is like as following,eVar14=Files|Milwaukee|page0where, the format is ||are you pointing to these 3 pipe symbol separated values that it the count is 3?

Views

1.1K

Likes

0

Replies

0
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Hi Lojmann,I printed the s.events variable, it looks correct and as expected. It just have one event (event77). There is exactly one image request which is triggered on the button click. it has the correct eVar and eventHowever, when i open the eVar report, i see multiple counts.No other processing rule that I see being triggered on click.

Views

1.1K

Likes

0

Replies

0
Re: Image request show Event is fired 1 time, but report display 7 times
Avatar
Validate 1
Level 2
PreetpalSinghBi
Level 2

Likes

10 likes

Total Posts

34 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 5
View profile
PreetpalSinghBi
- Adobe Analytics
Hi All,I see the following method to reset events. Can you please review if there are any side affects of this approach on my code and any other tag on the page?I see that the values get reset within the if condition scope before calling s.tl().I have not tested it to see if the count shows correctly yet, however, i did few console prints and I see the values become blank.Please review and suggest. SummaryI am resetting these 3 variables inside the if condition. s.linkTrackEvents = ''; s.events=...

Views

1.1K

Likes

0

Replies

0