Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Crxde lite query or home search does not show any results

Avatar

Level 3

I was trying to search for fields but crxde does not show any  results in home search or query tool.

chinmayis865517_0-1580793149985.png 

 

chinmayis865517_1-1580793201051.png

 

1 Accepted Solution

Avatar

Community Advisor

Hi Chinmay,

 

User should be logged in to AEM in order to search in crx/de console.

 

/Brijesh Yadav

1 Reply

Avatar

Employee

Hello Chinmay,

 

Which version of AEM are you using? I tried this search in my OOTB instance and was able to see result. Screenshot attached - Pic1.PNG

 

Also, you can use AEM query builder API (host:port/libs/cq/search/content/querydebug.html) to search from JCR. You will get the result in JSON format.

Avatar

Level 3
Hi Nidhip, I use AEM 6.4.4. I have tried to search in OOTB instance and the results did not show up there too.

Avatar

Level 3

Hi Nidhip,

I use AEM 6.4.4.
I have tried to search in OOTB instance and the results did not show up there too.

 

Avatar

Employee

1. Could you please check LastIndexedTime time from JMX console ./system/console/jmx --> IndexStats (This shows that when was last time index got updated).

It should not be stale. 

 

2. Also, try getting Debug level log on below index APIs - 

- org.apache.jackrabbit.oak.plugins.index

- org.apache.jackrabbit.oak.query

- com.day.cq.search

 

while you search. It will give a clear picture on what might be causing this.

 

If nothing helps, feel free to open Daycare ticket 🙂

 

Cheers,

Nidhi.

Avatar

Community Advisor

Hi Chinmay,

 

User should be logged in to AEM in order to search in crx/de console.

 

/Brijesh Yadav

Avatar

Level 3

Hi Brijesh

I am logged in.

I have this error -

*ERROR* [sling-default-5-HourlySnapshotJob] org.apache.jackrabbit.oak.plugins.index.lucene.BadIndexTracker Could not access the Lucene index at [/oak:index/lucene]

in error.log