Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Rule editor is not working in 6.3

Avatar

Level 3

Hi,

We have adaptive forms built in 6.1  (Without rule editor) and we have to migrate them to 6.3

We are able to install our form content package in 6.3. With the help of Dialog Conversion tool we are also able to launch rule editor. Now we have two problems.

1. Rule editor is not showing our existing rules.

2. When we are creating new rules its deleting all the existing rules

For example we have a textfield firstName.

We have valueCommitScript and initScript for this text field. If we are trying to create one more expression say validate Script through rule editor, we are loosing previous expressions.I can see that after creating rules from rule editor we are getting new new nodes

items/firstName/fd:rules

items/firstName/fd:scripts

Is there any tool or trick that we can migrate our expressions to rule editor ?

Thanks

Hitesh

0 Replies

Avatar

Level 2

Hi Hitesh,

Have you installed AEM 6.3 Forms add-on package [0] ? Also, we need to migration utility to migrate  Adaptive Forms , please follow the documentation at [1]

[0] AEM Forms releases

[1] Migrate AEM Forms assets and documents

Thanks

Nitin

Avatar

Level 3

Yes " AEM 6.3 Forms add-on package" is installed and we are following Migrate AEM Forms assets and documents  as well.

But after installing the migration utility I can access

http://[hostname]:[port]/[context path]/content/changeType.html

But not

http://[server]:[port]/lc/libs/fd/foundation/gui/content/migration.html

I am not sure whats wrong here. One thing I am not able to find "lc" in my nodes too. but http://localhost:4502/libs/fd/foundation/gui/content/migration.html exists. However that also doesn't work.

Avatar

Level 7

The /lc/ context is only for AEM Forms JEE, so should be removed if you have just a normal AEM Forms Author instance.

So http://localhost:4502/libs/fd/foundation/gui/content/migration.html should work fine in AEM Forms 6.3:

2017-06-27 08_59_09-AEM Form Migration.png

Avatar

Level 7

I also tested an old 6.1 adaptive form (pre-rule editor) and after running the migration tool, I have no issues with the Rule Editor.

Avatar

Level 2

Hi Hitesh,

As Darren sugested, So http://localhost:4502/libs/fd/foundation/gui/content/migration.html should work fine in AEM Forms 6.3

What does not seem to work with this link? As you mentioned in earlier conv.