Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Rule editor is not working in 6.3

Avatar

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
hitesh_m
Level 2

23-06-2017

Hi,

We have adaptive forms built in 6.1  (Without rule editor) and we have to migrate them to 6.3

We are able to install our form content package in 6.3. With the help of Dialog Conversion tool we are also able to launch rule editor. Now we have two problems.

1. Rule editor is not showing our existing rules.

2. When we are creating new rules its deleting all the existing rules

For example we have a textfield firstName.

We have valueCommitScript and initScript for this text field. If we are trying to create one more expression say validate Script through rule editor, we are loosing previous expressions.I can see that after creating rules from rule editor we are getting new new nodes

items/firstName/fd:rules

items/firstName/fd:scripts

Is there any tool or trick that we can migrate our expressions to rule editor ?

Thanks

Hitesh

Replies

Avatar

Avatar
Boost 1
Level 2
nitinn18425437
Level 2

Like

1 like

Total Posts

16 posts

Correct Reply

7 solutions
Top badges earned
Boost 1
Affirm 5
Affirm 3
Affirm 1
View profile

Avatar
Boost 1
Level 2
nitinn18425437
Level 2

Like

1 like

Total Posts

16 posts

Correct Reply

7 solutions
Top badges earned
Boost 1
Affirm 5
Affirm 3
Affirm 1
View profile
nitinn18425437
Level 2

25-06-2017

Hi Hitesh,

Have you installed AEM 6.3 Forms add-on package [0] ? Also, we need to migration utility to migrate  Adaptive Forms , please follow the documentation at [1]

[0] AEM Forms releases

[1] Migrate AEM Forms assets and documents

Thanks

Nitin

Avatar

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
hitesh_m
Level 2

26-06-2017

Yes " AEM 6.3 Forms add-on package" is installed and we are following Migrate AEM Forms assets and documents  as well.

But after installing the migration utility I can access

http://[hostname]:[port]/[context path]/content/changeType.html

But not

http://[server]:[port]/lc/libs/fd/foundation/gui/content/migration.html

I am not sure whats wrong here. One thing I am not able to find "lc" in my nodes too. but http://localhost:4502/libs/fd/foundation/gui/content/migration.html exists. However that also doesn't work.

Avatar

Avatar
Validate 10
Level 5
DarrenBiz
Level 5

Likes

67 likes

Total Posts

205 posts

Correct Reply

37 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 5
DarrenBiz
Level 5

Likes

67 likes

Total Posts

205 posts

Correct Reply

37 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
DarrenBiz
Level 5

26-06-2017

The /lc/ context is only for AEM Forms JEE, so should be removed if you have just a normal AEM Forms Author instance.

So http://localhost:4502/libs/fd/foundation/gui/content/migration.html should work fine in AEM Forms 6.3:

2017-06-27 08_59_09-AEM Form Migration.png

Avatar

Avatar
Validate 10
Level 5
DarrenBiz
Level 5

Likes

67 likes

Total Posts

205 posts

Correct Reply

37 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 5
DarrenBiz
Level 5

Likes

67 likes

Total Posts

205 posts

Correct Reply

37 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
DarrenBiz
Level 5

26-06-2017

I also tested an old 6.1 adaptive form (pre-rule editor) and after running the migration tool, I have no issues with the Rule Editor.

Avatar

Avatar
Boost 1
Level 2
Anish_Somani
Level 2

Like

1 like

Total Posts

19 posts

Correct Reply

4 solutions
Top badges earned
Boost 1
Affirm 3
Affirm 1
View profile

Avatar
Boost 1
Level 2
Anish_Somani
Level 2

Like

1 like

Total Posts

19 posts

Correct Reply

4 solutions
Top badges earned
Boost 1
Affirm 3
Affirm 1
View profile
Anish_Somani
Level 2

26-06-2017

Hi Hitesh,

As Darren sugested, So http://localhost:4502/libs/fd/foundation/gui/content/migration.html should work fine in AEM Forms 6.3

What does not seem to work with this link? As you mentioned in earlier conv.