Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Missing XMLForm.exe?

Avatar

Level 1

Whenever I try to submit data on AEM 6.0 forms or do some sort of processing, I see this error in the logs - Caused by: java.io.IOException: Executable does not exist: /Users/adobeuser/Documents/CQ/aem60/crx-quickstart/bedrock/svcnative/XMLFormService/bin/XMLForm.exe
    at com.adobe.service.ProcessResource.startProcess(ProcessResource.java:354)
    ... 281 common frames omitted

 

I checked the file location and it does not contain the .exe file. Am I missing something? I searched online for a solution but no luck yet. Any help is appreciated.

1 Accepted Solution

Avatar

Correct answer by
Employee

Please suggest if you have a pre-release aemfd package. If yes, we would recommend you to take the released bits available in AEM 6.0 official release. Such an issue was seen in one of the pre-release versions of the package. Also, make sure to install the OS specific package.

View solution in original post

6 Replies

Avatar

Employee

Vijay,

 

Were there any errors observed during the first installation of package? Can you upload error.log file?

 

 

--Santosh

Avatar

Correct answer by
Employee

Please suggest if you have a pre-release aemfd package. If yes, we would recommend you to take the released bits available in AEM 6.0 official release. Such an issue was seen in one of the pre-release versions of the package. Also, make sure to install the OS specific package.

Avatar

Level 1

Re-installation of the package adobe-aemfd-{OS}-pkg must resolve this issue. Please let me know the package version and CQ version you are using. Can you see some other files at this path as well?

Avatar

Level 1

Hello

We have the issue on our installation getting an error while posting the form.

Caused by: java.io.IOException: Executable does not exist: /opt/aem/crx-quickstart/bedrock/svcnative/XMLFormService/bin/XMLForm.exe

there is indeed a bedrock folder created under crx-quickstart but there is nothing under bedrock/svcnative/XMLFormService

I have followed the recommendation above and reinstalled the adobe-aemfd-linux-pkg-4.1.18.zip and restarted AEM but nothing happened.

Are there any instructions somewhere how to setup this pdf generation, some manual anything.?

Best Regards

Nikolas

Avatar

Level 10

Hi Nikolas,

Please refer to the below document and ensure that all the steps have been performed on the server:

Adobe Experience Manager Help | Install and configure PDF Generator

Avatar

Level 1

thank you for the reference.

I am reviewing it now, I forgot to mention that we are running AEMForms publisher on a linux CentOS host.

Best

Nikolas