Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments

Form is not passing certificate authentication to webservice

Avatar

Level 2

I have a process within my form that calls a webservice.  When the call is made I get the response:  

<html>Invalid client certificate: No client certificate provided</html>

No errors are being thrown because the 200 status is being returned with the response.

How do i get the certificate to go with the process request?

0 Replies

Avatar

Employee

Are you getting the same error using SOAP UI? Also, have you installed the WSDL server's SSL certificate in the AEM Forms server's java keystore?

Avatar

Level 2

This response is being given when trying to run the process from workbench.  It is also being received when calling the process form and adobe html 5 form on via our publisher server.  

Both the

Jboss keystore:     Valid from: Mon Mar 15 00:00:00 UTC 2021 until: Fri Apr 15 23:59:59 UTC 2022

Cacerts keystore: Valid from: Mon Mar 15 00:00:00 UTC 2021 until: Fri Apr 15 23:59:59 UTC 2022

are in place.

Avatar

Level 2

This was resolved. I think they had to enable the cert on forms server, I do not know for sure.  it is now working

Avatar

Employee Advisor

@jeanetter358457 I remember when I was with Adobe for service behinf 2 way SSL we had to 2 things:

1. Cert at the workbench level/SOAP component

2. cert at JBoss or whatever server you are using.