Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Exporting workflow - not working

crich2784
Level 4
Level 4

I have an adaptive form and a workflow that I need to export.  I followed the instructions here:

https://experienceleague.adobe.com/docs/experience-manager-65/forms/manage-administer-aem-forms/impo...

 

After uploading and installing the package on a new server, the workflow is not appearing nor is the Adaptive form.  I "downloaded" the adaptive form from the UI and that worked but, I still am unable to export the workflow.  Any advice (or point out what I overlooked) would be great!  Thanks.

 

Filters are:

/var/workflow/models/CentralCribRequestProcess

/conf/global/settings/workflow/models/CentralCribRequestProcess

/content/forms/af/ia/centralcribrequest

1 Accepted Solution
PulkitJain
Correct answer by
Employee
Employee

@crich2784 Do you see the new workflow under /conf/global/settings/workflow/models/ node path?

For creating a workflow package you need to add the filter : /conf/global/settings/workflow/models/workflowName and then make sure the workflow is synced from the models list on the new instance.

 

For creating a forms package you need to add the filter : /content/dam/formsanddocuments/formName and /content/forms/af/formName. You will find these two filters added in the "downloaded" adaptive form package as well.

 

Hope this helps!

View solution in original post

6 Replies
PulkitJain
Correct answer by
Employee
Employee

@crich2784 Do you see the new workflow under /conf/global/settings/workflow/models/ node path?

For creating a workflow package you need to add the filter : /conf/global/settings/workflow/models/workflowName and then make sure the workflow is synced from the models list on the new instance.

 

For creating a forms package you need to add the filter : /content/dam/formsanddocuments/formName and /content/forms/af/formName. You will find these two filters added in the "downloaded" adaptive form package as well.

 

Hope this helps!

View solution in original post

crich2784
Level 4
Level 4
Yes, I have two filters and it is sync'd. The process name is CentralCribRequestProcess. The filter is in my original post as /var/workflow/models/CentralCribRequestProcess /conf/global/settings/workflow/models/CentralCribRequestProcess - am I missing something?
crich2784
Level 4
Level 4

Yes, I have two filters and it is sync'd.

The process name is CentralCribRequestProcess.

The filter is in my original post as

 

/var/workflow/models/CentralCribRequestProcess

/conf/global/settings/workflow/models/CentralCribRequestProcess

 

am I missing something?

PulkitJain
Employee
Employee
@crich2784 Lets connect over a quick call, are you available right now?
crich2784
Level 4
Level 4
@PulkitJain I am traveling at the moment. I can send you my package if you give me an email address. crich@source360group.com
PulkitJain
Employee
Employee

@crich2784Thanks for sharing the package! I uploaded the workflow on my in-house set-up and could see the workflow added under the path </conf/global/settings/workflow/models/>.

To ensure that the workflow is active, we have to sync the workflow. Double click on the workflow from crx, switch to editor mode and sync the workflow with the new instance. You'll be able to invoke the same as expected.

Please raise a ticket with Adobe support, in case of any questions/issues further. We will setup a screenshare session to walk you through the steps.