Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

How to re-process existing assets after adding a new smart crop - without losing original crop adjustments

Avatar

Level 3

Hi,

 

we've uploaded over a 1000 assets with 7 smart crops set in the image profile.

 

We now want to add 3 more smart crops - and apply them to all existing images.

 

We can do this by running the 'dynamic media re-process assets' workflow.

 

BUT....

 

any adjustments to smart crop setting on any of those original images are LOST when we run that workflow.

 

Does anyone know how we can get the new smart crops available to existing assets WITHOUT losing any of the changes already made ?

 

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 3

Hi,

 

just to bring this to a close.

 

Adobe acknowledged that this is a bug, and have already coded a fix that they are planning to go live both for Cloud and Managed Service Assets instances by end of May 2024.

 

Good news - once it's live !!

View solution in original post

13 Replies

Avatar

Community Advisor

Hi @GeraintJo ,


this is strange. I just tried to replicate this behavior.
But maybe I did something different.
Can we compare the steps that you did to mine?

Step 1: I created a image profile - called it test.
Step 2: a added some smartcrops - 1:1 - 2:3 - 3:2 
Step 3: i attached this profile to a folder with some images. -I reprocessed the images so that they will contain the smartcrops from the setting.
Step 4: I changed the smart crops - so that i will be able to see if my next step will reset them.

Step 5: i added more smartcrops to the same profile. 16:9 - 1:12
Step 6: Reprocess the images

My previously edited smart crops stayed as i set them - the new smart crops are available.

Avatar

Level 3
mmmm
 
that's what I did yes.
 
What workflow did you use ?
 
Maybe something different in our 'Dynamic Media  Reprocess assets' workflows ?
 
G

Avatar

Community Advisor

I just selected the assets and clicked the reprocess (full process) button from the action bar.

AdilosCantuerk_0-1713508738149.png

Avatar

Level 3

OK - that looks like a custom task for you  - as we don't have that option.

 

It looks like a very different action bar.

 

Is that the app, or assets essentials ?

 

Does it start a w/flow - can you tell what the w/flow is ?

 

Thanks

Avatar

Level 3

aghh - yes that will be it.

 

does anyone know what the equivalent is for full blown Assets ?

Avatar

Community Advisor

Could you please elaborate - what do you mean by "full blown Assets"?

Avatar

Community Advisor

I am sorry to say, that I do not know the details of Assets managed service.
In AEMaaCS we did not face these troubles. I recommend that you open up a ticket with the adobe support and wait what they come up with. This behavior is really not how it should work.
Maybe somebody else wants to comments in here?

Avatar

Community Advisor

@GeraintJo in AEM 6.5, it is Dynamic Media : Reprocess Assets. Can you please try using DAM Update Asset once? 

Avatar

Level 3

@diksha_mishra 

DAM update asset does a full reset as it re-runs all the uplaod processing.

That definitely doesn't work

 

Avatar

Administrator

@GeraintJo  Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni

Avatar

Correct answer by
Level 3

Hi,

 

just to bring this to a close.

 

Adobe acknowledged that this is a bug, and have already coded a fix that they are planning to go live both for Cloud and Managed Service Assets instances by end of May 2024.

 

Good news - once it's live !!