Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Uploaded fonts are not displaying correctly in HTML landing page

nikitap46765450
Level 2
Level 2

Hi All,

There is a case where in we are uploading a landing page in web applications. The fonts and js files been used in the html are uploaded in 'Public Resources' manually. But when we are trying to preview the landing page, the fonts are not getting reflected i.e it is showing the text with default fonts.

Landing page with fonts

1591948_pastedImage_1.png

Landing page where the fonts are not getting reflected

1591952_pastedImage_2.png

Thanks & Regards,

Nikita Pramanik.

3 Replies
Garima_Gakhar
Employee
Employee

Hi nikitap46765450

When you say the fonts and js files been used in the html (Landing Page) have been manually defined in Public Resources section, kindly confirm is this being done by duplicating an existing Landing Page Template.

nikitap46765450
Level 2
Level 2

Hi Garima,

The landing page has being created from scratch and not being duplicated.

Vapsy
Employee
Employee

Hi Nikita<https://forums.adobe.com/people/nikitap46765450>,

Please launch the developer tools on the browser and open the console tab.

Check for any errors.

I have a feeling that the fonts are not getting loaded because of CORS.

Possible reason, the public resources are being fetched from a different domain (probably Adobe) but the landing page is using customer branding subdomain.

If this is true, change the subdomain to match your branding and the problem will be gone.

Regards,

Vipul