Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Data is not pulling from Recipient table in HTML

holmes74338504
Level 4
Level 4

All,

I've tried to make the following code work and I can not seem to get this to work in ACS. If I go into EDIT > HTML and hardcode the cusID, then my email will pull necessary content for my email.

I need help identifying why the code below will not pull the ID from recipients.

                                          <div class="mj-column-per-100 outlook-group-fix" style="vertical-align:top;display:inline-block;direction:ltr;font-size:13px;text-align:left;width:100%;">

                                            <table class="border-all" border="0" cellpadding="0" cellspacing="0" style="background:#fff;" width="100%">

                                              <tbody>

                                                <tr>

                                                  <td align="center" style="word-wrap:break-word;font-size:0px;padding:0px;" class="">

                                                    <table align="center" border="0" cellpadding="0" cellspacing="0" style="border-collapse:collapse;border-spacing:0px;">

                                                      <tbody>

                                                        <tr>

                                                          <td style="width:550px;"><a href="#" target="_blank" data-nl-type="externalLink" data-nl-lnkep-perso-attr-href="https://www.companyname.com/us/en_us/rewards?CID=eml-rewardsrecap-november" data-id="al15741937708074c0605"><img src="http://mi.companyname.com/p/rp/5e3c3449d904fe60.png?mi_u=%%cusPARTY_NUMBER%%&amp;mi_user_id=%%cusID%%&amp;" style="border:none;border-radius:0px;display:block;font-size:13px;outline:none;text-decoration:none;width:100%;height:auto;" width="550" data-nl-imgep-perso-attr-alt="Hello Rewards Member!" class=""></a></td>

                                                        </tr>

                                                      </tbody>

                                                    </table>

                                                  </td>

                                                </tr>

                                              </tbody>

                                            </table>

                                          </div>

1 Reply
SatheeskannaK
Community Advisor
Community Advisor

Hi,

Can you try below one and add inline styles anything you have,

<img src="http://mi.companyname.com/p/rp/5e3c3449d904fe60.png?mi_u=&amp;lt;%= escapeUrl(context.profile.cusPARTY_NUMBER)%&amp;gt;&amp;amp;mi_user_id=&amp;lt;%= escapeUrl(context.profile.cusID)%&amp;gt;">

Let me know if this helps.

Thanks!