Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[API Create Profile] Profile receive 201 but they don't appears between profiles table

Avatar

Level 3

Hi All,

 

I have an integration that creates profiles with API Calls. Time to time happens that a profile is created in campaign but it doesn't appear on the profile table.

 

If I tried to do the same API Call I receive an error because there is already that primary key.

What is also strange is that if in a workflow I do reconciliation with that profile Id, the profile appears in the keep interim result log with all the information I've inserted previously through the API Call.

 

I tried to contact Adobe but they are not able to give me any solution.

 

Did anyone of you experience this problem?

0 Replies

Avatar

Employee Advisor

Do you have permission handling with organizational units enabled on your instance?

Or do you have any link on the profile table which could prevent the display? (i.e. a 1:1 link with missing target)

Avatar

Level 3

Yes I've permission and no I don't have any table 1:1.

 

All the customers are imported through API and this impact small number of customers.

Avatar

Level 6

If your using organization make sure you are using the ProfileAndServicesExt endpoint and not the ProfileAndServices endpoint.

Avatar

Level 2

Hi @gabrieleg615679,

 

Just wanted to check, Is profile table linked with any other table. If yes, does the linked table has data related to the primary you are entering in the Profile table. My understanding is, your linked table doesn't have data related to the primary key you are inserting in the profile table. Please check once.

Avatar

Administrator

Hi @gabrieleg615679,

Were you able to resolve this query with the help of any of the given solutions or do you still need more help here? Do let us know.
Thanks!