Expand my Community achievements bar.

Do you have questions about the migration to Adobe Business Platform? Come join our upcoming coffee break and ask away!
SOLVED

Add multiple emails in "To Recipient" in Workfront Fusion microsoft email module

Avatar

Level 2

Hi,

 

I was working on a fusion scenario where I was trying to send a single email to multiple users by using Microsoft 365 email module. Here If I add more emails by clicking "add items" button its sending separate emails to users. I want to do a single send email operation to mulitple users. Please let me know if this is possible.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

make sure that the input array for the recipient field has this format:

Rafal_Bainie_0-1696840219544.png

 

it should be ok, that's how it works for us

View solution in original post

8 Replies

Avatar

Community Advisor

Hi,

this is actually doable!

Recipients field needs to contain an Array:

Rafal_Bainie_0-1696508393477.png

 

that array comes from processing all "tagged users" in our case (we read them from note, all users tagged on an update) in a simple loop:

Rafal_Bainie_1-1696508512961.png

module 36 uses "Tags" array as input from Read note module, important here is that you read user's email address.

Hope this helps

Avatar

Level 2

Hello,

 

Thanks for your quick response and I tried this but unfortunately it's not providing the expected result. I'm able to get the required email address from Workfront but facing the problem when Microsoft 265 email module comes into play. I was not able to enter multiple emails in "To Recipient" field. I have attached the screenshot of the error.

RathinaGopalan_0-1696520704718.png

Please let me know if you need any more details

Avatar

Correct answer by
Community Advisor

make sure that the input array for the recipient field has this format:

Rafal_Bainie_0-1696840219544.png

 

it should be ok, that's how it works for us

Avatar

Level 2

Hello @Rafal_Bainie,

 

I have tried your suggestion but still facing some issues. I have pasted the screenshot so you can take a look and let me know if I did anything wrong.

The input of the To Recipient field was in the below format.

1.png

2.png

 

But after this also I'm still getting the same error.

3.png

 Please let me know whether what I have done here is correct or Do I need to change anything here.

Avatar

Community Advisor

It seems it's very small detail.

Error message is very specific - module expects field called "address" (as in my screenshot above), and the one you are providing is "emailAddr".

I hope that updating this will resolve your problem.

Cheers!

Avatar

Level 2

Thanks @Rafal_Bainie. It worked, now I was able to map data to "To Recipient" field but still got one Run time error.

 

RathinaGopalan_0-1696919622689.png

Can you please help me to fix this one too.

 

Thanks in advance,

Rathina

 

Avatar

Community Advisor

5xx indicates usually some sort of server/connection issue, but it can also be something outlook specific. 

I cannot help with this, I would review outlook account settings or reach out to your IT team to help you out with this.