Expand my Community achievements bar.

The next phase for Workfront Community ideas is coming soon. Learn all about it in our blog!

Create User Accounts via the Workfront API

Avatar

Level 4

10/3/23

Description - Before the upgrade to the Adobe Admin Console, we could create users via the API. It now creates them in a pending approval state and we have to manually approve them. 

Why is this feature important to you - This is causing a bottleneck in quickly on-boarding users to Workfront.

How would you like the feature to work - I'd like it to work as it did before :), or allow an option to be set to pre-approve the users. Or even a separate API call to approve the user.

Current Behaviour - Account is created, but requires manual approval, once approved the account is made in the Adobe Admin Console.

 

16 Comments

Avatar

Level 1

11/15/23

I wanted to bump this thread to see if there was any progress. Migrating to ABM broke our ability to auto-provision users. We started looking at using the API to replicate this functionality, but reading this thread makes it seem like we need a workaround for the workaround. 

Avatar

Level 2

11/15/23

We ended up rolling back our production instance off of IMS about 2 weeks ago until Adobe addresses this issue later in Q1FY24.  Until then, we are now back to normal in production but have IMS enabled in Preview and Sandbox so we can continue testing in those environments when the problem is "fixed".

Avatar

Level 4

11/15/23

@bfan

It's very frustrating. Some people seem to think the old creation method should work if the API user is a product admin, others think it will never work. All I know is I'm every admin possible and it still doesn't work.

 

Adobe User Management API is still not working, they are still "gathering information" with no ETA on a fix.

 

@brmorril I think you made the right decision. The change management was too much for us to roll it back. I will let you know when we get it working

 

Rob

Avatar

Level 4

12/19/23

Hi all,

We finally got this working. It's not as pretty as before. I create the account in Workfront using the original code I had.

I then use the API to create the account in Adobe Admin Console via that API. It then seems to setup correctly and the user no longer needs approving. 

I've had one report that the account still needed activating, but it generally seems to work. 

Hopefully one day they will fix it so we don't need the 2nd step. But I'm not holding my breath

Regards,

Rob

Avatar

Level 1

1/4/24

 

With workfront API, provide an option to activate users up on creation via the workfront API's. Currently users are created in a "deactivated" state and requires manual action to activate.

 

Why is this feature important to you: We have an automated user provisioning workflow in place and the above limitation is causing a holdup requiring a human intervention to activate user account.

 

Expected behaviour: Workfront user creation API's should be able to create the user account that in an activated status. Either the  user create API should be updated or provide separate Workfront API to activate the user.