Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Best practices for adding external Rich Text to Workfront Rich Text fields

Avatar

Level 1

Does anyone have a best practice solution for bringing text into a Workfront Rich Text field. We are finding when moving text from Rich Text fields in other applications that we are running into characters that are not accepted such as trademark and bullet symbols and we are losing things like URL links and highlighting. Salesforce is one of the source applications where this has been a recurring problem. Is there a parser that can take Rich Text in various formats and bring it easily into the JSON required by the Workfront Rich Text field?

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

3 Replies

Avatar

Level 10

Hi Bret, what modules are you using to move the text over to Workfront? I don't think there should be an issue if its Create or Update Record, but if it was a custom API call you might run into issues unless you first use the "Create JSON" module to place the text into and then send that JSON as the body of your API query.

Avatar

Level 1

I have a very simple scenario...

  1. Read a Salesforce opportunity and capture a Rich Text field
  2. Update a Rich Text field in Workfront with the SF value

Using Update Record like you would for a normal field does not work because it is expecting a JSON payload.

I tried using a Custom API call and that at least got basic text from SF into the WF field, but it is erroring out on a variety of characters such as trademark and bullets.

I didn't think there should be an issue either, but apparently you cannot treat WF Rich Text fields like other fields.

Avatar

Level 10

Ah you are updating a "text field with formatting" in WF, I missed that part, we haven't started using those fields but i'm guessing its similar issues to the typeahead field issue I ran into last year in Fusion, they cannot be updated in the same way as a simple text field.

If its working when there is no special characters but failing when there is, they probably just need to be escaped. Are you using the "Create JSON" module before sending it via the custom API card, have you an example of a query body you sent to WF that failed?