since ‎05-02-2016
‎10-12-2019
ralvarado88
Level 2
Re: Cannot get HttpContext trough BundleContext in AEM 6.4 ralvarado88 - Adobe Experience Manager
Hi guysAs you mentioned above, the HttpContext service is not available in AEM 6.3 and 6.4The good news is that what this service did in 6.2 was using the org.apache.sling.auth.core.AuthenticationSupport handleSecurity method, and the AuthenticationSupport service is available in 6.3 and 6.4.I managed to solve it by creating a custom HttpContext that inside uses the AuthenticationSupport class. I explain it here:https://medium.com/@rijoalvi/aem-6-4-httpcontext-use-case-5824e486ebaf Thank you all...
3701
Views
2
Likes
2
Replies
Re: Cannot get HttpContext trough BundleContext in AEM 6.4 ralvarado88 - Adobe Experience Manager
Thanks! actually the service is not available in 6.3 and 6.4No idea why it is not
3701
Views
0
Likes
0
Replies
Cannot get HttpContext trough BundleContext in AEM 6.4 ralvarado88 - Adobe Experience Manager
Hi!I am working on migrating some bundles from AEM 6.2 to 6.4 and I ran into the following issue:I have an Activator.java in a bundle with the following code:@Overridepublic synchronized void start(final BundleContext bc) throws Exception { myBundleContext= bc private ServiceTracker tracker = new ServiceTracker(myBundleContext, HttpService.class, null) { @Override public HttpService addingService(ServiceReference sRef) { ServiceReference httpSRef = bundleContext.getServiceReference(HttpContext.c...
3984
Views
3
Likes
8
Replies
Re: AEM 6.4 beta, Apache Sling JCR Resource Resolver not present ralvarado88 - Adobe Experience Manager
Thanks! Yes, apparently it was an issue with my jar. Thanks for your help!
2091
Views
0
Likes
0
Answers
AEM 6.4 beta, Apache Sling JCR Resource Resolver not present ralvarado88 - Adobe Experience Manager
Hi allI'm trying to migrate an app so it works on AEM 6.4 beta, but I ran into the following problem:When I install my bundle. I get the following error:org.apache.sling.jcr.resource,version=[2.4,3) -- Cannot be resolvedRight now, I'm using version 2.9.2 of org.apache.sling.jcr.resource. Here's the pom dependency: org.apache.sling org.apache.sling.jcr.resource 2.9.2 provided I checked in AEM's web console, and searched for that dependency using the dependency finder ( http://localhost:4502/syste...
10287
Views
5
Likes
25
Answers and Comments
Re: AEM 6.4 beta, default login is not working ralvarado88 - Adobe Experience Manager
Thanks! That solved the issue
926
Views
0
Likes
0
Answers
Re: AEM 6.4 beta, default login is not working ralvarado88 - Adobe Experience Manager
Hi, I'm having the exact same issue. when I try to login user admin/admin, I get a "User name and password do not match" error.Please keep us updated if you manage to solve it! Thanks!
913
Views
0
Likes
0
Answers