ralvarado88
Community profile ralvarado88 Level 2
Job title here
Location here
8 BADGES
Level 2

Level 2

Learn more
Joined the community 05-02-2016 2:44:12 PM
Offline
Top badges earned by ralvarado88
Customize the badges you want to showcase on your profile
Re: Cannot get HttpContext trough BundleContext in AEM 6.4
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Hi guysAs you mentioned above, the HttpContext service is not available in AEM 6.3 and 6.4The good news is that what this service did in 6.2 was using the org.apache.sling.auth.core.AuthenticationSupport handleSecurity method, and the AuthenticationSupport service is available in 6.3 and 6.4.I managed to solve it by creating a custom HttpContext that inside uses the AuthenticationSupport class. I explain it here:https://medium.com/@rijoalvi/aem-6-4-httpcontext-use-case-5824e486ebaf Thank you all...

Views

4.1K

Likes

2

Replies

2
Re: Cannot get HttpContext trough BundleContext in AEM 6.4
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Thanks! actually the service is not available in 6.3 and 6.4No idea why it is not

Views

4.1K

Likes

0

Replies

0
Cannot get HttpContext trough BundleContext in AEM 6.4
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Hi!I am working on migrating some bundles from AEM 6.2 to 6.4 and I ran into the following issue:I have an Activator.java in a bundle with the following code:@Overridepublic synchronized void start(final BundleContext bc) throws Exception { myBundleContext= bc private ServiceTracker tracker = new ServiceTracker(myBundleContext, HttpService.class, null) { @Override public HttpService addingService(ServiceReference sRef) { ServiceReference httpSRef = bundleContext.getServiceReference(HttpContext.c...

Views

4.3K

Likes

3

Replies

8
Re: AEM 6.4 beta, Apache Sling JCR Resource Resolver not present
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Thanks! Yes, apparently it was an issue with my jar. Thanks for your help!

Views

2.6K

Likes

0

Replies

0
AEM 6.4 beta, Apache Sling JCR Resource Resolver not present
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Hi allI'm trying to migrate an app so it works on AEM 6.4 beta, but I ran into the following problem:When I install my bundle. I get the following error:org.apache.sling.jcr.resource,version=[2.4,3) -- Cannot be resolvedRight now, I'm using version 2.9.2 of org.apache.sling.jcr.resource. Here's the pom dependency: org.apache.sling org.apache.sling.jcr.resource 2.9.2 provided I checked in AEM's web console, and searched for that dependency using the dependency finder ( http://localhost:4502/syste...

Views

11.0K

Likes

5

Replies

25
Re: AEM 6.4 beta, default login is not working
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Thanks! That solved the issue

Views

1.2K

Likes

0

Replies

0
Re: AEM 6.4 beta, default login is not working
Avatar
Validate 1
Level 2
ralvarado88
Level 2

Likes

10 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back
Ignite 1
Boost 5
Boost 3
View profile
ralvarado88
- Adobe Experience Manager
Hi, I'm having the exact same issue. when I try to login user admin/admin, I get a "User name and password do not match" error.Please keep us updated if you manage to solve it! Thanks!

Views

1.2K

Likes

0

Replies

0